NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

couldn't add a simple VI into Teststand

Hello,

I am new to Teststand. I have created a simple VI in Labview with a button and added the VI into Teststand through Labview Module window. I get a warning Icon, which says " Unable to load VI ***.vi with the labview runtime engine version 13.0, The version of a subVI might not match the version of the run-time engine or a VI dependency might be missing"

 

Configuration:

Labview: 2013 f2

labview runtime: 2014 SP1 f3( which got updated recently, previously it was 2013 f2)

 

Teststand: 2014

Teststand runtime: 14.0.0.274

 

Please help me how to proceed.

 

0 Kudos
Message 1 of 2
(2,192 Views)

The error message is pretty clear.

Two possible reasons:

1. RTE (RunTime Engine) version is not the same as the development version of the VI. Either configure the LV Adapter for "Autodetect" (which is default) or the correct version which you used for development of the VI (e.g. LV 2013).

2. The VI is depending on subvis which cannot be found. Please note that the LV RTE does NOT know about vi.lib, user.lib and instr.lib. You have to create a LV source distribution for the VI in order to make the VI executable. Use the LV AppBuilder directly or via the TestStand Deployment Utility to create this package. LV AppBuilder is mandatory for this.

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 2
(2,180 Views)