NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Why isn't my GPIB-ENET device an option in MAX after TestStand deployment?

I have built a Test Stand deployment that includes NI MAX and what I think are all the required drivers and components. I go to my test machine after installing the deployment and try and configure MAX. I am trying to create a new GPIB-ENET/100/1000 device however under Network Devices that is not an option. This is the first deployment I have built since upgrading to this version from 2013. I am now running NI Developer Suite 2016. I have done this many times before. Any ideas as to what could be missing from my deployment file that would keep me from having this option? I have more choices than before as far as different things to add but none is the GPIB-ENET device.

 

Thanks in advance for any help.

 

Troy

0 Kudos
Message 1 of 5
(2,376 Views)

So I went and created my GPIB-ENET controller using the GPIB Ethernet Wizard. It worked fine, found my controller, and is working properly. The next problem with it now is I cannot scan for my instruments. The option is not there. I imported my .nce file and my aliases etc are showing up under my system. However the option to scan for instruments is not there so I am still stuck. Any help with this one would be appreciated. I still think this is related to the fact that I couldn't create a new GPIB-ENET controller within MAX itself.

0 Kudos
Message 2 of 5
(2,365 Views)

Hi,

 

Can you provide a screenshot of the Software dropdown in MAX so I can see what drivers you have installed? In particular I want to make sure you have NI-488.2 installed.

James F.
Applications Engineer
National Instruments
0 Kudos
Message 3 of 5
(2,356 Views)

James, you beat me to the update. I actually called into support this morning and the problem is resolved. I did not see the check box in the deployment utility under drivers and components that was checked to only display runtime installers. Therefore I only had the NI-488.2 15.5 runtime installed which does not allow configuration of the GPIB-ENET device in MAX. After un-checking the box I could now see the NI-488.2 15.5 Application Development Support 15.5. I included that in my deployment and that fixed the problem. I simply overlooked the check box so the configuration drivers were not selected or installed.

 

Thanks for looking into this for me.

 

Troy

Message 4 of 5
(2,354 Views)

Ahh. Glad you got it working!

James F.
Applications Engineer
National Instruments
0 Kudos
Message 5 of 5
(2,334 Views)