NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Vision Builder AI Server disconnects if any network connections changes occures

I'm posting this subject may help others. I do not have bullet- proof solution, but at least I have figured out when it is poping up, hopefully NI will work for solution in the next releases of Vision Builder AI.

If you start the VBAI server with certain network connection available, this will stay alive until any of you computer network connection changes the connection state. After a network connection change, the Server will report  "Host_disconnected"( seen with SocketSniffer):

 

Send: Return Code: 0x00000000
00000000 01 00 00 51 D7 00 00 00 11 48 4F 53 54 5F 44 49 ...Q.....HOST_DI
00000010 53 43 4F 4E 4E 45 43 54 45 44 SCONNECTED

 

If you run now an inspection will fail with error:

Vision Builder AI:  (Hex 0xFFFA9600) The connection to the remote target was lost because another user has connected to the remote target,

see attached picture:

 

VBAI_Server_Error.png

 

If you set back the network connections to the state when the server was started, it will work fine again. 

 

My setup: 

-TestStand 2012

- Vision Builder AI 2014

- Wireless NIC ( DHCP)

- NIC (DHCP)

- Microsoft Loopback adapter ( fix IP=192.168.1.1) - this was installed after first errors I have seen, just to have an fix IP, in hope to have host network binding to this adapter. Did not help!

 

Thanks

0 Kudos
Message 1 of 6
(4,414 Views)

What do you mean by "until any of you computer network connection changes the connection state"?

0 Kudos
Message 2 of 6
(4,396 Views)

Connection state changes means, one of your network connections disconnects or connects, unplug ethernet cable from NIC example.

0 Kudos
Message 3 of 6
(4,389 Views)

Dear csgyorgy,

 

I will contact you via private e-mail so we can discuss the issue further. The results will be posted here in the end.

0 Kudos
Message 4 of 6
(4,353 Views)

After Closing the connection (without stopping the VBAI Server) and Opening it again, the Inspection works as expected. Using the appropriate precondition in TestStand ensures that the Error Handling only runs when necessary.

0 Kudos
Message 5 of 6
(4,328 Views)

Dear Tamas, 

Can you please explain in a bit more detail? Closing the connection is not working in our case. In fact nothing is working. Even disconnecting the server and re-connecting is erroring out. 

0 Kudos
Message 6 of 6
(1,094 Views)