NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to load LabVIEW VI into TestStand using LV Run Time only

Solved!
Go to solution
Highlighted

Hi Manooch,

 

Sent you my details.

 

 

Alan

0 Kudos
Message 21 of 31
(3,530 Views)
Highlighted
Solution
Accepted by topic author eric.atherton

I just wanted to direct other users to the KnowledgeBase article that describes the cause of the issue most people on this thread have run into, along with the solution.

 

Why Can I Not Call a LabVIEW 2010 (SP1) VI from TestStand Using the LabVIEW 2010 (SP1) Run-Time Engi...

Manooch H.
National Instruments
Message 22 of 31
(3,502 Views)
Highlighted

Hi Manooch,

 

I also have issues with TestStand 2010SP1 and the LabVIEW 2010 SP1 runtime.

 

Is this thread still alive ??

 

Here's a copy of an e-mail I sent to NI Support:

 

I have 3 testsystems. 
At this moment they all have teststand 2010SP1, LabVIEW 2010SP1, DAQmx 9.4.0f1, GOOP4.5 and a few OpenG packages.
Licenses at this moment: TestStand Base Deployment Engine and LabVIEW Professional Development system.
The LabVIEW Adapter in teststand is 'Development System'
 
I have a few sequences in teststand.  Each step calls a LabVIEW vi from my LabVIEW Project.
With the above settings all works fine. 
 
 
But now ...  I want to deactivate the LabVIEW Professional Development system. 
I deactivated the license on my testsystems (because they will be shipped to the customer). I just deactivate, the runtime and all other LabVIEW files are still on the same place on the pc.
In stead of the Developement system adapter in TestStand, I now choose LabVIEW Run Time Engine.
 
Then, when i run my slotgeneric.seq  i get the error that TestStand can not load xxxxxx.vi   
 
There is no strange stuff in the labVIEW code, just some classes, DAQmx code , ...
 
I searched the NI website for help and found 1 forum topic and 1 knowledge base:
 
I followed all steps in the knowledge base, but without succes.
  
TestStand should be able to open .vi's with the runtime adapter.
 
My boss, suggested to try a deployment of the sequences and LabVIEW code.
So I made a deployment. This gives me a copy of my sequences and called LabVIEW code but the in another directory on disk.
If i run these sequences on my testpc's ... they all work.  They are still just .seq files that i open in teststand and i have all my vi's in a separate folder ...
 
 
I hope someone can help me out.
0 Kudos
Message 23 of 31
(3,090 Views)
Highlighted

Wim.Tormans -

 

When you configure TestStand to execute VIs using the LabVIEW Run-Time Engine, all VIs called throughout the test must be saved by the same version of LabVIEW (the version that you set when configuring the LabVIEW Adapter to use the LabVIEW Run-Time Engine. This includes VIs called directly from the TestStand sequence, VIs called as subVIs of the VIs called directly from the TestStand sequence, and VIs called dynamically (using VI Server) from VIs that fall into one of the two previously mentioned scenarios.

 

When calling VIs from TestStand using the LabVEW Development System, you do not face this same restriction because the LabVIEW Development System will automatically re-compile any VI, that is saved in a previous version of LabVIEW, when attempting to load the VI.

 

You are experiencing errors because the LabVIEW Run-Time Engine cannot load one of the VIs used by your test application. Some steps that might help:

 

1. When you receive the error, it should tell you which step in your sequence the error is related to, and may also mention the name of the VI that the step is calling.
2. If it mentions the VI name, open the VI using the LabVIEW Development System (this may require you to evaluate the LabVIEW Professional Development System or re-activate it briefly).
3. When the VI is open, see if the title bar displays an asterisk (*) indicating that the file has changed.
4. Force a re-compile of the VI by clicking the Run arrow while holding Ctrl+Shift.
5. Select File»Save All.
6. Close LabVIEW.
7. Open TestStand and see if you still receive the error. If you do receive an error, be careful to note whether the error refers to the same step and same VI or if it refers to a different step and different VI. It's very possible that a number of the subVIs and library VIs used in your test application need to be re-compiled and saved by LabVIEW 2010 SP1. If this is the case, you might be able to resolve this issue in a more timely manner by mass-compiling all of the VIs used in your test application.
 
Hope this helps.
Manooch H.
National Instruments
Message 24 of 31
(3,072 Views)
Highlighted

Hi Manooch H.

 

Teststand indeed tells me which steps fail.

 

I stripped one of my sequences to keep 1 failing step.

 

I opened the vi that i call in LabVIEW and didn't see the 'dirty dot'. However, still did the ctrl-shift run.  And it saved a lot of library vi's (Open G) and a few motor classes that i use.

 

Afterwards, the sequence was able to load ...

 

I'll do some further tests next week and let you know the result.

 

Best regards,

Wim

0 Kudos
Message 25 of 31
(3,066 Views)
Highlighted

OK, it all works now.

 

However, deploying seems very usefull to service our customer when the systems have moved.

 

But I'll keep this solution in mind when I have the same error again in other projects.

 

Best regards.

0 Kudos
Message 26 of 31
(3,044 Views)
Highlighted

You may want to consider using the TestStand Deployment Utility to deploy your TestStand application.

Manooch H.
National Instruments
0 Kudos
Message 27 of 31
(3,038 Views)
Highlighted

Manooch H.

 

I'm already using it.  Building an installer of the code is easy and easy to deliver to my customer when he needs a few changes.

 

Wim

 

0 Kudos
Message 28 of 31
(3,030 Views)
Highlighted

Hi,

 

I am trying to complete the TestStand tutorial, and in part 11 Calling LabView VIs (Test stand User manual) I am supposed to load VIs from the NI Template.

I am using TestStand 2014 32-bit, seq editor 14.0.0.274, and LabView 2013 SP1.

I am facing the same problem, warning message appears: "Unable to load VI LabVIEW Pas-Fail Test.vi with the LabVIEW Run-Time Engine version "11.0" The version of a subVI mighht not match the version of the run-time engine or a VI dependancy might be missing."

 

On the following link http://digital.ni.com/public.nsf/allkb/1AC89FA9E9424B6A86257904000624B4?OpenDocument

it says that the problem is only with LabView 10 or earlier.

 

On my system I have LabView run-time engine 14. What should I do?

0 Kudos
Message 29 of 31
(2,544 Views)
Highlighted

Try changing your LabVIEW adapter to the 2013 Development system.

 

Run time can have issues with recompile and linkage to vi's.

 

The dev env is better with this.

0 Kudos
Message 30 of 31
(2,514 Views)