NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Testand engine 32 bit launch error



Hi ,


I have used the simple teststand user interface shipped with teststand and i customized it for my application.  I am using teststand 32 bit and labview 32 bit . After i customized and build the exe .

and when i run the exe i got the error as attached snapshot.


Anyone faced this issue. Do i need to configure any setting before building exe. Kindly note i have installed only teststand 32 bit and labview 32 bit on my system.





0 Kudos
Message 1 of 10

Hi AnandR,


Do you have multiple version of TestStand on the machine? If so, did you change the active version in between the build and the launch of the user interface? 


Since TestStand engine uses ActiveX/COM technology, there can be only one active version. This should be the version of the engine used to for the user interface development. 

0 Kudos
Message 2 of 10

Hi Roxana,


I have only teststand 32(2016 SP1) version on my system. Also earlier mentioned i am using labview 32 2017 and windows 8 64 bit OS.


The above error popup comes from the teststand API GetEngine present in the Initialize state of simple user interface. See the attached pic.





0 Kudos
Message 3 of 10

Also note that  i will get this error only when i run the user interface from the build exe.



Note:  Earlier when i started customizing the the simple user interface , i copied the simple user interface from teststand 64 bit version. So base version of customized simple user interface is 64 bit. Later i started working on Teststand 32 with same source code. 

0 Kudos
Message 4 of 10



The error code is -17500 FYI.





0 Kudos
Message 5 of 10

I've the same issue. Have you found solution? 🙂

0 Kudos
Message 6 of 10

After quick research and trial-and-error session, I've found the solution, but I still don't understand the reason...


It works when I assign TS UI controls to my class properties out of my Message Handling loop. When I do that inside, it does not work (the same error as @AnandR.

Assign TS UI controls" is one of the first messages, before that one I handle only a few initialization messages and they have nothing to do with TS API. I'm a bit confused, I'm fine with that solution, but I hope I will find and understand the reason. Capture.PNG



Anybody could explain it to me, please?



Message 7 of 10



Did you solve it? 


I have the same problem.



0 Kudos
Message 8 of 10

Hi, I just use the workaround I showed on the screenshot, I didn't spend more time on it.

Mateusz Owczarek

Certified LabVIEW Architect
Certified TestStand Architect
0 Kudos
Message 9 of 10

Crazy, but it works.  

Thanks 😊 

0 Kudos
Message 10 of 10