NI TestStand

Showing results for 
Search instead for 
Did you mean: 

TestStandElevatedCommand not Found

Go to solution

I'm trying to change the Source Code Control Provider to None, and I'm running into an issue with this error: 


TestStandElevatedCommand Not Found.JPG


When I go to that folder, that file is indeed not there.  


I have verified that I have admin rights, and I have tried "Run as Administrator", but same response.


Has anyone else seen this problem?

0 Kudos
Message 1 of 3
Accepted by topic author Seth_K



I agree with you that this is a problem; I'm seeing it on my test system as well. I've filed a report on this issue so that we can investigate it; it will be tracked with CAR ID 579926.


As far as working around the issue, I am assuming you are trying to change the Source Code Control Provider setting for a workspace. If this is the case, you can save the workspace file as XML and edit it manually to make the change. Here are steps to do that:


1) Go to Configure > Station Options > File tab > File Format Options, and change the format of the workspace file to XML.

2) Save the workspace file.

3) Open the workspace file in a text editor and look for the following section:


<SccProviderName classname='Str' valueflags='8'>
<value>Perforce SCM</value>


4) change the data inside the <value> tags to the following:




5) If you were previously using the default SCC provider, you might also need to set the <SccUseDefaultProvider> class to false instead of true.



These steps should allow you to disable SCC for the workspace, but if you run into any trouble with it, let me know and I'll be happy to help you with the changes. Thanks for reporting the issue to us!

Daniel E.
TestStand Staff Product Support Engineer
National Instruments
Message 2 of 3

Hi Daniel,


Thanks for the prompt response.


The instructions you gave solved that problem.  




0 Kudos
Message 3 of 3