NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

TestStand doesn't communicate with a cRio

Hey guys,

 

I solve an interesting problem at my work: We have a tester based on cRio, which is controlled by the TS sequence under the base deployment engine.

 

When I make the deploy and test it on the laptop with the TS Development, everything works correctly (I can read the inputs, set the outputs etc.), but when I use the PC with TS Base deployment engine, the sequence starts to run without reporting any error and the VI's in sequence doesn't communicate with the cRio at all (I cannot set or read anything).

 

I tried to check the VI's, which seems to be executable with all dependencies, I can see the cRio in MAX and I can approach its IO's in the Distributed Systems manager. I don't think, that there's a problem in the HW, but I suspect that something is missing in the deploy, or that there is some problem with the network shared variables I use in the code.

 

I couldn't find a similar problem on the forum, could anyone help me with that? Thanks in advance!

 

Simon

0 Kudos
Message 1 of 2
(199 Views)

I had probably identified the problem - it seems, that the network shared variables are the issue. Could anyone advice me, how should I add them to the TS workspace and deploy?

I tried to add the libraries with them to the seq. file in the TS workspace, but this didn't work and I was still prompted with the error message about missing dependencies.


Thanks a lot!

 

Simon

0 Kudos
Message 2 of 2
(139 Views)