NI TestStand

Showing results for 
Search instead for 
Did you mean: 

TestStand Sequence Editor message

When TestStand is launched, getting a popup window - 'Value must be at least 0'. What does that mean?

Will it make any effect on test sequence execution?

0 Kudos
Message 1 of 14

This is a rather unusual error--I have not heard of it before, so we'll need to do a bit of further debugging to determine the cause. Here are a few questions that might help us narrow this down:


Could you attach a screenshot of the error message?

Does it occur before or after you see the login dialog in TestStand?

Has this always occurred, or did it recently start occurring?

Which version of TestStand are you using, and on which operating system?



0 Kudos
Message 2 of 14

To add:

I assume that you re-load the sequence files which were not closed last time you closed TS. Is it possible that one of that has a "SequenceFileLoad" callback implemented?

Does this error occur with any user interface or in the NI Sequence Editor only? If it only occurs in one UI: What makes this UI special? Is it custom made?



CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 3 of 14

Any clues on how to solve this situation?

I ended up having this same problem today.

Every time I open teststand application I get this popup with "Value must be at least 0"

If I click OK, it will go away, but I can't open any sequence, existing or new one.

Also if I try to open a .seq through workspace, I get another error message. (see below)


EDIT: found this on the internet, but did not solve either:






0 Kudos
Message 4 of 14

Up, I have exactly the same issue with NI TestStand Engine Version 2019 ( 32-bit....


Help from an NI Employee please ?


EDIT : Can you please delete this knowledge base ? It simply doesn't work...

0 Kudos
Message 5 of 14

Another step to try is to rename your users.ini file to something else and then Reopen TestStand so it creates a new users.ini in case there is something wrong with the ini file when you open TestStand and it starts the login routine. 

Dane S.
Product Support Engineer
National Instruments
0 Kudos
Message 6 of 14

Hi Dane !


I just tried to rename Users.ini.

TS indeed creates a new Users.ini file, but the issue is still here unfortunately...


That's weird. Should I try to delete all the Cfg folder ?


EDIT : I tried to rename the 2 only files which were modified the day the bug appeared ("StationGlobals.ini" & "TeststandPersistedOptions.opt", last modification 9/17/2020). I tried as well to copy and paste those 2 files from another PC with a correct TS.
Issue is still here...

0 Kudos
Message 7 of 14

Hi Bilsix,

Thank you for bringing this to our attention. I have passed your feedback to our web content team to review.

Best Regards,
Kristi Martinez
NI Community Support
0 Kudos
Message 8 of 14

Could you potentially try to capture a crash dump of TestStand with the error dialog you are seeing up? We likely will want to have a better understanding of the state TestStand is in, to proceed.

Dane S.
Product Support Engineer
National Instruments
0 Kudos
Message 9 of 14

Hi Kristi, Hi Dane !


The issue is solved thanks to a Staff TSE from Paris named Karim El Oueldrihi !


You can find in attachment 2 screenshots of the issue :

  • The first one ("Value must be at least zero.png") shows what was happening when I tried to open TS.Value must be at least zero.png


  • The second one ("All greyed out.png") highlights the fact that I couldn't even try to create a new Sequence File.All greyed out.png

Basically, the solution was pretty easy for me : Karim told me that an internal KB suggested to try to fix the software (via the "National Instruments Software" of the Windows Control Panel,

I selected only TestStand 2019 (32-bit), waited 15min for the repair, restarted the PC and voilà !


I asked Karim to modify the public KB related to this issue, which is useless at the present time :


Well, the problem is solved, I can continue to develop. Thanks !

0 Kudos
Message 10 of 14