NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

TestStand 2010 SP1 Timeout on mySQL.

Dear,

 

 TestStand 2010 is configured to log data to external mySQL server database (via IP).

 I'm using TestStand 2010 SP1, ODBC 5.1, WINDOWS XP SP3

 I sometimes get the following timeout error (see attached) :

 

An error occurred calling 'LogResults' in 'ITSDBLog' of 'zNI TestStand Database Logging'

An error occurred executing a statement.

Schema: MySQL Insert

Statement: mesure.

Description: [MySQL][ODBC 5.1 Driver][mysqld-5.0.94-enterprise-log]MySQL server has gone away

Number: -2147467259

NativeError: 2006

SQLState: 08S01

Reported by: Microsoft OLE DB Provider for ODBC Drivers

Source: TSDBLog

 

I already check using of INSERT command (SELECT seems to be slower).

I also attached the ODBC configuration

Do you have any idea about the way to fix it ?

 

Regards.

 

0 Kudos
Message 1 of 8
(1,905 Views)

I suggest you google the specific error you are getting back from mySQL. In this instance you don't appear to be the only experiencing this issue...

 

http://lmgtfy.com/?q=MySQL+server+has+gone+away

CTA, CLA, MTFBWY
0 Kudos
Message 2 of 8
(1,898 Views)

Hi, we're trying to troubleshoot the same thing.  Does anyone know, when does teststand open and close the database connection?  We are not "logging on the fly", so I would assume teststand only tries a connection at the end of the sequence, when it logs by running the insert commands.  Is this correct?  Also does it close the connection after logging?  Or are these connections completely manages by the ODBC connection in windows?  We're running win7 x64, teststand 2012. 

 

Thanks

David Jenkinson

0 Kudos
Message 3 of 8
(1,619 Views)

Hi David,

 

I am also facing same issue and I am using on the fly logging option in result processing. You got anyways to handle this error in teststand?

 

Regards,

Narra

0 Kudos
Message 4 of 8
(1,468 Views)

Hi,

I've opened a recent ticket, having to do with this issue, and have been trying various remedies.  We do have an error handling sequence, which we could use to mask it, but we'd still lose the data.  So I've kept it prompting when we have an error.

 

I have implemented a couple things which _seem_ to help, but time will tell.  On my end it appeared that the error was implying that the microsoft odbc connection was in error, but when I went to the dialog in windows, and did a "test connection" it passes, even though  repeated re-tries in teststand failed with the same error.  So I do know about a caveat in setting up the odbc connection in 64-bit windows.  

http://support.microsoft.com/kb/942976:

 

So one thing I did was set up both the 32-bit and 64 bit versions, just in case one was being used in some circumstances for whatever reason. I also enabled "force reconnection" in the options of the respective odbc configs.   I also re-built our connection string in teststand with the "build" button in the data link tab of database options, it seemed to add one field called  "initial config" or something like that .  I also have enabled "share data link between executions" at the bottom of the data link window.  I'm not sure the latter is a help though because I did observer the error in both states. 

 

I am still in experimentation but in the last several days I have not seen this error after doing the above.  Crossing my fingers.

0 Kudos
Message 5 of 8
(1,459 Views)

Hi David,

 

Thanks a lot for your reply.

 

Basically I am also trying out some options. But i could see there are no issues with the ODBC drivers. From My SQL web resources, I see this issue comes because of timeout.

 

By default, Teststand opens connection to database when execution starts up in case of OTF logging and if execution haulted because of some reason in teststand, then by default My SQL config had timeout setting of 28800 secs (8 hours). So if no data is going to database, My SQL will through this error. So we need to handle this error with engone callback functions.

 

I am trying some sequences for this and let you know once its solved.. Smiley Happy

 

Thanks,

Narra 

0 Kudos
Message 6 of 8
(1,437 Views)

Hello Narra and David,

 

 I solved this problem by checking the boxes on my ODBC windows (see pdf enclosed on top)

 - Allow big result sets

 - Enable automatic reconnect

 

Maybe it will be the same for you.

Regards.

Jérôme.

 

 

 

0 Kudos
Message 7 of 8
(1,431 Views)

Hi,

I did know about the automatic reconnect option, but not about the big results option.  I will try that out too.  Thanks for the tip.

 

Also there are potential server based rememdies, which we have implemented in the past, but still got errors.  But these may help in other environments:

 

http://dev.mysql.com/doc/refman/5.0/en/gone-away.html

0 Kudos
Message 8 of 8
(1,418 Views)