NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

TS-OPUI shows Passed but there are fail-tests - why?

Hello,

i am using TS4.2.1 and LV8.6 in WIndowsXP. There i use the default TS-OPUI.

In the TS-OPUI there is in the left side a Execution-list with a final-result Passed/Failed and a color green/red.

When i click on a execution then it shows me on the right side the report of this execution.

 

Now i have the problem that TS shows a final result of PASSED but there are some fail-tests in the sequence that are shown in the report.

 

How is this possible?

 

Thanks

 

 

0 Kudos
Message 1 of 7
(2,158 Views)

Hi

 

Check if on all desierd steps the flag "Step Failure Cause Sequence Failure" is set to true.

 

Screen1.JPG

 

 

regards

 

Juergen

--Signature--
Sessions NI-Week 2017 2016
Feedback or kudos are welcome
0 Kudos
Message 2 of 7
(2,156 Views)

None of my steps has this flag disabled 😞

 

I saw in the reports that all "wrong" results also have an "ERROR"-step inside.

Is it possible that the error overwrites the normal result (which should be fail) with passed?

 

0 Kudos
Message 3 of 7
(2,153 Views)

Hi,

 

That is possbile

Just visit this old thread:

http://forums.ni.com/t5/NI-TestStand/Force-TestStand-Step-to-Fail-When-Error-Occurs/m-p/435510

 

regards

 

Juergen

--Signature--
Sessions NI-Week 2017 2016
Feedback or kudos are welcome
0 Kudos
Message 4 of 7
(2,150 Views)

Now i created a dummy sequence that contains dummy-labview-vis (one is pass, one fail, one error)

When running the sequence then the report says "Fail" but the Icon in Teststand shows a green Passed-Icon.

Does someone know which variable sets this final-icon in the Execution-list?

(In the model the Main-sequence-callback finished correct with "error".)

Thx

0 Kudos
Message 5 of 7
(2,148 Views)

I am getting nearer...

When the error occurs then Teststand shows me the RunTimeError-occured-popup (screenshot).

 

When selecting here: runCleanup -> then the result goes on Pass

When selecting here: ignore -> then the result goes on Fail.

 

I am sure that it is somewhere in the model.

Because when using the default-model (and not my custom model as above) then the result is going correct on Error when selecting runCleanup.

The question is nonly: Where is this set?

0 Kudos
Message 6 of 7
(2,142 Views)

I fouond the missing line:

0 Kudos
Message 7 of 7
(2,139 Views)