NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Stuck on analyzing sequence file

Solved!
Go to solution

Hello,

 

I've been developing a sequence file for a while and until recently there was no problem running it.

Now all of a sudden when i try to execute the sequence file from the sequence editor i gets stuck on "Analyzing Sequence File" at about 35% completion. Nothing happens when i press "Skip Analysis" or "Cancel Execution".

 

I've tried setting run mode to skip on all steps as well as restarting my PC but it still doesn't work.

 

Any help appreciated.

0 Kudos
Message 1 of 3
(165 Views)

Hi,

 

a college of mine just had the same problem. Can you try to disable the analyzing and see if running the test is also getting stuck on preloading modules? This may give you a hint on which Module is corrupting your Sequence.

In our case LabVIEW was the Problem, somehow Teststand was not able to start it.

 

Br Michi

0 Kudos
Message 2 of 3
(114 Views)
Solution
Accepted by topic author MattiasU

Turns out the problem was that I was calling RunUserInterface() from DllMain() which prevented the dll from being loaded correctly. I didn't realize that the dll was loaded during the analysis phase in TestStand so I incorrectly believed that my dll had nothing to do with the problem.

0 Kudos
Message 3 of 3
(95 Views)