NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Run a Sequence with Teststand API

Solved!
Go to solution
Highlighted

Hi fellow Devs,

 

I'm trying to run a sequence using TestStand API, Using the below Method

4.JPG

The loop runs fine till new Execution and then hangs in wait to end the execution property. Till then was working good. After waiting for some time recieved a message pop up that the time limit has exceeded and prompts to terminate the execution.

Can anyone figure out what i'm missing in here.Please Help

 

A BIG THANKS IN ADVANCE

 

0 Kudos
Message 1 of 5
(259 Views)
Highlighted

Is there a reason you need to get/run the sequential model?  If the first sequence you load is using the sequentialmodel, you shouldn't need to load the model separately.

0 Kudos
Message 2 of 5
(205 Views)
Highlighted

Hi,

 

It seems the vi is not the problem. I tried running another example sequence (Mobile Test) and my own sequence which has only functions from the teststand. Both the sequence are running perfect. My sequence contains editted preUUT sequence file callBacks and are using labview vi for actions and numeric Test and also some property loader steps. I found no other difference from the running sequence and my sequence.

Anything I need to set ??

0 Kudos
Message 3 of 5
(194 Views)
Highlighted

I guess I don't think so, but what you're doing is unusual.  What happens if you run the client sequence on its own and replace the model callback with the edited PreUUT you described in your post?

0 Kudos
Message 4 of 5
(174 Views)
Highlighted
Solution
Accepted by topic author AswinPRaj

Yes Bro,

The operation was unusual as it seems. Lol

I managed to make it work by removing the preUUT from the sequence and by editing the original PreUUT callback from the sequentialModel.seq. The sequence is working fine Now. Thanks for the hand of help 😊

 

[Updated] And also the waitforEndEx must be removed if we are using the vi from a UI Thread

0 Kudos
Message 5 of 5
(168 Views)