NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Preloading Modules very slow when no source for PPL

Hello,

 

I have made a sequence with LabVIEW libraries. I worked with PPL, so I referenced my LV project file, with the VI in the lvlib :

Config LV Step.png

I set the Override Settings to target the right Build Specification :

Override Steeings.png

 

When I was developping, during my tests, I had the Preloading Modules window. I always used the "Always run VIs in PPL" in the LV adapter options. Everything was fine.

Preloading Modules.png

 

Now, I need to go to production mode. So I deleted sources, and keep only PPL (lvlibp), and lvproj of course.

 

It is working at the end, but the "Preloading Modules" window is very very very slow (few minutes).

 

Do you know what's happening ?

 

 

Message 1 of 6
(151 Views)

Hi,  Can you please post the files to reproduce this issue?

0 Kudos
Message 2 of 6
(96 Views)

How do you manage dependencies in your project? Do you have your driver in labview\instr.lib directory? Are you sure that TS/LV can easily find your driver? I'm guessing that you have a problem with relative paths.

Michał Bieńkowski
CLA, CTA

Someone devote his time to help solve your problem? Appreciate it and give kudos. Problem solved? Accept as a solution so that others can find it faster in the future.
Make a contribution to the development of TestStand - vote on TestStand Idea Exchange.
0 Kudos
Message 3 of 6
(76 Views)

Hello,

 

All my drivers are packaged in a lvlib.

I attached a sample sequence with drivers. I also attached CPX400DP drivers if needed (provided by TTi company).

For this example, I timed the launching, from Click on "Execture >> Test UUT (F5)" until the dilogbox requesting UUT Serial number, here are the results :

- Sources directory keeped : 21s

- Sources directory removed : 4mn 40s (This is huge long time !)

 

Sequence is stored in "D:\Sequences\SomeTestSequence.seq" (D mounted via Windows command)

I have the following settings for this test :

LabVIEW Adapter Configuration :

LV Adapter Config - Advanced.PNG LV Adapter Config - General.PNG

 

Search Directories :

Search directories.PNG

 

Thanks for your help.

 

Download All
0 Kudos
Message 4 of 6
(67 Views)

Can you try to use lvlibp (packed)?

Michał Bieńkowski
CLA, CTA

Someone devote his time to help solve your problem? Appreciate it and give kudos. Problem solved? Accept as a solution so that others can find it faster in the future.
Make a contribution to the development of TestStand - vote on TestStand Idea Exchange.
0 Kudos
Message 5 of 6
(64 Views)

Il used lvlibp, but via the "Always run VI in Packed Project Library" LV adapter option.

The idea is to develop in LV edition mode, for the debug. When I want to push to production the sequence, I check the PPL option and I remove sources.

 

Of course, I can target directly the VI in the lvlibp, but I'm trying to use the PPL LV adapter option (available since TS 2019).

0 Kudos
Message 6 of 6
(58 Views)