From 12:00 AM CDT Sunday, October 17 - 11:30 AM CDT Sunday, October 17, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

NI VISA cannot install

I have a problem with installing  NI VISA.  It was installed my computer but when I run my python script it was giving me an error.

I googled the root cause of error and in couple forums It was saying uninstalling and installing NI VISA can help or to solve the issue.

NI VISA is removed and installed coupled times. I also removed some files that is started with NI_VISA. 

RIght now,  when I tried to install the visa I am seing the below message. Also, I cannot see the National Insturements Folder in the Start Menu.

Can someone help me to figure out the installing issue?

 

"

Cannot install

  • NI-VISA 5.4.1

Run Time Support (higher version already installed)

Configuration Support (higher version already installed)

Development Support (higher version already installed)

Remote Server (incompatible with products already installed)

  • NI Measurement & Automation Explorer 5.5 (higher version already installed)
  • NI-1588 Configuration 1.3.0 (higher version already installed)

 

Adding or Changing

  • NI-VISA 5.4.1
  • NI System Configuration 5.5.0"
0 Kudos
Message 1 of 2
(2,307 Views)

The error message basically says that you already have a VISA version on your machine which is never that the one you are trying to install.

 

Probably, there are some leftovers in the registry. So either clean the registry, or try to install an appropriate version.

Already registered for GLA Summit 2021? Why not?

GLA Summit 2021
0 Kudos
Message 2 of 2
(2,285 Views)