NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Mysterious errorcode -17306 "Unknown variable or property name"

Go to solution


I've been working on a system to save and recall arbitrary JSON files and have run into an issue. When running the code it works fine for almost all cases but not my final test of trying to save a calibration file to the disk. During the test i get the following error.



This is perplexing as my sequence is quite straight forward as shown below



The process works for both TestContainer2 and TestContainer3 where TestContainer3 is made to include all the data cases that is in the CalibrationFile container.


Here's the stuff I've tried to replicate the issue elsewhere.

- Tested Custom Typed vs generic containers

- Tested similar container styles(TestContainer3)

- Tried recreating the python module step

- Checked paths and variable references

- Verified that the read data get transferred correctly to the CalibrationFile container before attempting export

- Running the export step without importing data first and therefore attempting to save default values to the disk

- Running the code without TestStand to verify that my code works as intended

- Tried using a differently named calibration file variable

- Tried using a calibration file variable that's stored in FileGlobals instead


I'm at a bit of a loss as to what to try next. Any ideas on how to fix this or is it a case where a bug report is needed to solve this issue?

I'm using TestStand Engine Version 2023 Q4 ( 64-bit and Sequence Editor Version 2023 Q4 (23.8) 64-bit.

Thanks in advance

- Malte





0 Kudos
Message 1 of 14

The previous step sets the Locals.CalibrationFile.  It is possible that step is not doing what you intend.


How is the python script accessing the container, via PropertyObject API calls?

0 Kudos
Message 2 of 14

From what i could tell there isnt an API version for python but if there is id love to get my hands on one!


But no all containers are passed over as tuples and i can see in my variable panel that the previous step does what i intended and copies over the data to the CalibrationFile variable. However even if it didnt i would expect the export function to work but just save the default values of the CalibrationFile container.

0 Kudos
Message 3 of 14


Can you try passing Locals.CalibrationFileReturn.Result for your container parameter?

0 Kudos
Message 4 of 14

I tested it and it gave me the exact same error.


0 Kudos
Message 5 of 14

@MalteGS wrote:



...all containers are passed over as tuples...


You say you are passing tuples can you explicitly set your parameter from Dynamic to Tuple?

0 Kudos
Message 6 of 14

Sadly this didnt have an effect either

0 Kudos
Message 7 of 14

Have you stepped your python module to see if that reveals anything?

How Do I Attach a Debugger to My TestStand Sequence for Python? - NI

0 Kudos
Message 8 of 14

I've tried to attach the debugger to the process but ive been unable to do it in the specific case of the failing step "Export Calibration File". It works just fine in other instances. My current understanding of the situation is that the process ID popup doesn't appear because the error happens before the python code is executed. The error occurs while trying to pass the container to python but for some reason TestStand is unable to locate the container it is trying to pass.

0 Kudos
Message 9 of 14

I noticed a pattern in your sequence file of:

  1. Import
  2. Move
  3. Export

However, your last export has another step; can you try skipping the highlighted statement?



0 Kudos
Message 10 of 14