NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple UUT Result

Solved!
Go to solution

Hello Community,

 

Teststand 2014 32bit

Using Schema for result processing.

 

I have a Main sequence and a regular sequence used for a message prompt only.

The regular sequence gets called from the Main sequence, displays a message, and the loop waits for the Pass/Fail Test to result true.

Once the Pass/Fail Test completes, then I terminate the Call execution of my regular sequence, which is shown in my database as UUT_STATUS Terminate.

I only want to log my Main sequence, which is the one in the image with a UUT_STATUS of failed.

It shows up as having two Unique IDs in my UUT_RESULT table.

 

How can I keep the regular sequence from being logged in my database?

 

Download All
0 Kudos
Message 1 of 8
(2,795 Views)

Additional information

The other sequence(s) i do not want to be logged to my database has an Entry Point: Single Pass and Execution Options: Use New execution.

The Action step taken is an ActiveX/COM. Module setup is Object Class: Execution, Call Method, and Terminate.

0 Kudos
Message 2 of 8
(2,770 Views)

Hi MechUnit,

 

You can go to File > Sequence Properties on the sequence you want to disable the result for and select "Disable Result Recording for All Steps" which would stop it from displaying the information you don't want.

Sunayna R.
Applications Engineering
National Instruments
0 Kudos
Message 3 of 8
(2,716 Views)

Hi Sunaenae,

 

I tried that, but that only stopped the steps inside the sequence from displaying in the Schema STEP_RESULT.

The sequence itself still shows up as a record in the Schema UUT_RESULT.

0 Kudos
Message 4 of 8
(2,688 Views)

Hi MechUnit,

 

On the Step Settings for the SequenceCall step, you can go to Properties > Run Options and choose Result Recording Option as Disabled. This should prevent the sequence from showing up on the report. More information about this function can be found here: http://zone.ni.com/reference/en-XX/help/370052N-01/tsref/infotopics/db_step_prop_run_opt_tab

Sunayna R.
Applications Engineering
National Instruments
0 Kudos
Message 5 of 8
(2,652 Views)

Sunaenae,

 

I tried that as well Smiley Indifferent

The step settings for result recording are for that particular step in the sequence only.

It still shows up as if I am testing two UUTs in my database result processing, because I have my main sequence and the other sequence being called as a new execution.

 

0 Kudos
Message 6 of 8
(2,642 Views)
Solution
Accepted by topic author MechUnit

Why are you running the prompt with a process model?  In your Sequence Call Advanced Settings change the Process Model Options to Do not use a process model. The process model is the one that writes the results to the database.  If you change it to not use a model then it won't touch the database.

 

See the image.

 

Hope this helps,

jigg
CTA, CLA
testeract.com
~Will work for kudos and/or BBQ~
Message 7 of 8
(2,634 Views)

Jiggawax,

 

I learned something new. That seemed to have done the trick. Smiley Happy

 

Thank you both for your help and time

0 Kudos
Message 8 of 8
(2,609 Views)