NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple Numeric Limit Hide "Unused" Outputs In Test Report

Solved!
Go to solution

Hello,

 

I have a question relating to Multiple Numeric Limit Test and output report in ascii txt format:

 

Sample Measurement, this is what I see in the txt file:

 

 Measurement[74] :
              Limits:
                 Low:             4.75
                 High:            5.25
                 LowExpr:         ''
                 HighExpr:        ''
              Units:              V
              Comparison Type:    GELE (>= <=)
              CompExpr:           ''
              UseCompExpr:        False
              Data:               5
              Status:             Passed

 

Is there anyway I can hide or "not include" the unused portion of the output?  In this case I don't need LowExpr, HighExpr, CompExpr and UseCompExpr.  It will make the report cleaner and easier to navigate...essentially this:

 

 Measurement[74] :
              Limits:
                 Low:             4.75
                 High:            5.25                                 
              Units:              V
              Comparison Type:    GELE (>= <=)
              Data:               5
              Status:             Passed

 

Regards,

Mike

0 Kudos
Message 1 of 5
(2,122 Views)

I see the following when I create a new multinumeric limit test:

 

Multiple Numeric Limit Test:   Failed
     Measurement:
        Measurement[0] (Measurement 0):
           Limits:
              Low:             9
              High:            11
           Comparison Type:    GELE (>= <=)
           Data:               0
           Status:             Failed
        Measurement[1] (Measurement 1):
           Limits:
              Low:             9
              High:            11
           Comparison Type:    GELE (>= <=)
           Data:               0
           Status:             Failed

 

I think it's supposed to work exactly like you are wanting it to. Perhaps there is some issue with how the step involved was created or modified or converted. Can you reproduce this problem with a newly created and specified step? Also, please specify what version of TestStand you are using.

 

-Doug

0 Kudos
Message 2 of 5
(2,114 Views)

Hmm, I think I am closing in on what is going.

 

Doug, if I just do a normal call to multi lim test I get the same result as you.

 

However, I am using a code an user posted on this forum which allows you to load an array of results and limits:

 

 Untitled.jpg

 

I am trying to figure out what is in here that is causing all the "extra" outputs.

 

Regards,

Mike

0 Kudos
Message 3 of 5
(2,098 Views)
Solution
Accepted by topic author mwcmwc

You are probably missing a flag that is supposed to be there for some properties (i.e. PropFlags_DontCopyToResults). I can't see enough details in your screen shot to see why it's happening, but if you make the middle column bigger or post what all of the expressions are you are using, I might be able to see what's going on. You can manually/programmatically readd this flag to some of the properties, but it should really be set by default on the expr properties already so I'm not sure why it isn't in your use case. The steptype itself sets the flag at runtime on the LowLimit and HighLimit as needed for the case in which only one or neither limit are used. It's generally expecting the flag to already be set the other properties that need it at edit time.

 

You can look through the source code at:

 

TestStand\Components\StepTypes\CommonSubsteps\

 

to see how the multinumeric limit step type sets the flag.

 

Hope this helps,

-Doug

0 Kudos
Message 4 of 5
(2,086 Views)

Sorry for the late reply.  I think this will work!

 

Regards,

Mike

0 Kudos
Message 5 of 5
(2,047 Views)