NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Mathscript in VIs to use in Teststand

Go to solution



I'm using Teststand to create a small test sequence where I need to use a VI with a MathScript Node executed by MathScript RT Module. In MathScript Node I have a filter_zerophase and when I add this VI to an action in TestStand the message "Unable to load..." appears on Module tab. If I remove the filter_zerophase of the MathScript node everything works fine. Any one knows why this happens?

In this link ( we can see that filter_zerophase is supported in the LabVIEW Run-Time Engine.





0 Kudos
Message 1 of 3
Accepted by topic author rgpbrito

Hi Ruben,


The reason why you are unable to load a VI with a MathScript node is because MathScript requires specific VIs from the LabVIEW library. You need to create a source distribution for your VI that would include the required libraries and then load the your VI from the source distribution.

You'll find here an article in the NI Knowledge base that details the procedure:


Hope this helps!


Best regards,



Message 2 of 3
Accepted by topic author rgpbrito

Hi Karim
Thank you ... I had already tried this procedure, but unfortunately it hadn't worked.

Once you've suggested this approach, I've tried it again and it didn't work again. However, I realized that I was choosing the relative path instead of choosing the absolute path.

Best regards,



0 Kudos
Message 3 of 3