NI TestStand

Showing results for 
Search instead for 
Did you mean: 

LabVIEW vi fails to load with run-time engine 2017

Go to solution



I'm getting a strange error I have a few TestStand sequences on a machine. The system has 2 windows accounts on it. One account can run all the sequences in run-time mode while the other has issues loading some of the VIs in run-time. The search directories match up and I already did a mass compile which worked since they run on the other windows account. 


Any one run into something like this?



0 Kudos
Message 1 of 5

Just a thought; is it possibly a user privilege access problem? Where are your VIs stored?  Are they stored in a location that your first user can access but your second cannot or can following some sort of privilege elevation?


i.e.  Browsing files in Windows explorer; all users are able to access files (VIs) in C:\Users\Documents\Public but user1 is only be able to access files in C:\Users\Documents\user1, all other users need a privilege elevation to access the files in C:\Users\Documents\user1.

0 Kudos
Message 2 of 5
Accepted by topic author smercado



That was my first thought, as I have had that happen before but it was not. 


I did figure it out. So the issue was that there were two folders on the system with identical VIs (names and code) in different locations. When in development mode Teststand sorts out the file paths but in run-time the LabVIEW project does. It just so happened that the LabView project resolved the path on one user account a few times and then when tested on the other it could not. once I deleted the duplicate folder and resolved the conflicts in the project. it all worked correctly. 

0 Kudos
Message 3 of 5

Good stuff.

0 Kudos
Message 4 of 5


So you just delete the duplicate folder and resolve the conflict to fix the problem?

Anything else need to be taken care of?

0 Kudos
Message 5 of 5