NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW: VI server access denied.

Solved!
Go to solution

A week or so ago I was trying the LabVIEW Desktop Execution Trace Toolkit for Windows. To enable it, I had to go to LabVIEW>Tools>Options>VI Server: Configuration and enable the TCP/IP check box under protocols. The tool works fine, but now I cannot edit or run VI's from TestStand.

 

In the Step Settings window in TestStand, I get the red exclamation mark comes up with the error "LabVIEW: VI server access denied." This started happening immediately after I enabled the TCP/IP check box, but it won't go away after I deselect it or restart LabVIEW/TestStand etc. I've toggled the LabVIEW adaptor to run-time mode and back to development. Error still there.

 

I saw a few related threads here on the forum, but nothing that seems relevant.

 

I am using LabVIEW 8.6 and TestStand 4.1.

0 Kudos
Message 1 of 5
(2,375 Views)
Solution
Accepted by topic author drewsali

I believe you're running into a bug in the toolkit which inadvertantly locks out VI server access. Check out the following article and see if the remedy works for you: http://digital.ni.com/public.nsf/allkb/75D823EF2C4EBEC086257554005767A2

0 Kudos
Message 2 of 5
(2,370 Views)

Thanks for the link. I had not seen that. Unfortunately the HighlightObject By Context-VI-UID.vi Allow access option is already selected. I toggled it and restarted just to be sure. Looks like there are other settings in that dialog that I could experiment with.

0 Kudos
Message 3 of 5
(2,366 Views)

You've misread the document. You need to replace the "HighlightObject By Context-VI-UID.vi" entry with a single asterisk (which means any).

0 Kudos
Message 4 of 5
(2,363 Views)

Ah, that's it. Thank you.

0 Kudos
Message 5 of 5
(2,360 Views)