NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

LV Channels breaks VI when loaded into RTE in TS Seq

Hi Forum members,

 

I have attached a simple example of the issue I am facing. This VI contains a simple channel wire writer & reader for waveform array data type.

 

While using LV dev as an adapter, everything loads and runs fine. When configured to use LV RTE, TS could not load and complains that the channel wire dependencies could not be found and causing a bad linkage.

 

Historically, I had faced the same issue on other computers and I solved them by clearing out the Channel cache from Documents\LabVIEW Data\2019(64-bit)\ExtraVILib\ChannelInstances\

 

Things tried,

  • Clear Channel cache
  • Open VI, delete the channel wires and recreate from scratch on the end-computer

Appreciate your thoughts, anyway going to create a support ticket with NI on this.

 

LV 2019 64-bit f2

TS 2019 64-bit f2

TSM 2019 64-bit

Win10 64 bit

 

Tried on an 8881 controller and also an HP laptop.

 

In order to observe this error, open the VI and save it (to recreate the channel instance on your computer), open TS, change adapter to RTE and run seq analyzer.

BTW - not configured for version-independent RTE, so there should be no issues with searching for dependencies

Santhosh
Soliton Technologies

New to the forum? Please read community guidelines and how to ask smart questions

Only two ways to appreciate someone who spent their free time to reply/answer your question - give them Kudos or mark their reply as the answer/solution.

Finding it hard to source NI hardware? Try NI Trading Post
Download All
0 Kudos
Message 1 of 1
(661 Views)