NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

How to exclude "Skipped" tests from the final report? (The TestStand 2013)

Solved!
Go to solution

Hello,

 

Background

I have 5 tests running in a For-Loop. Each loop iteration corresponds to one row in my database table. These tests use a Pre Expression to set the Step Name.

 

For some loop iterations, it doesn't make sense to run 1 out of the 5 tests. Here, I use a Precondition to skip the test.

 

 

Problem

When the Precondition fails, the Pre Expression doesn't run. That means the Step Name remains unchanged from the last iteration which ran the test. So, the report shows the wrong name being skipped.

 

 

Possible solutions?

The ideal solution is to not have the Skipped tests appear in the report at all. Is there a way to achieve this?

 

If not, we can live with the line that shows "Skipped" in the report, if the Step Name is updated to match the others. Is there a way to achieve this?

 

Or, are there any other suggestions?

 

 

Thanks!

Certified LabVIEW Developer

0 Kudos
Message 1 of 2
(3,683 Views)
Solution
Accepted by JKSH

Hi,

 

There is an option in report settings.

Its under Include step results --> Result filtering Expression :

You need to give this : Result.Status != "Skipped"

 

This will avoid skipped tests in the report.

Hope this helps.

 

Ravi

Message 2 of 2
(3,673 Views)