NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Error in step: instrument reserve (-6 user defined code)

I'm doing the training couse of teststand.


Could anybody help me with this error please?



Thanks so much.

0 Kudos
Message 1 of 8

Hi cristina.lopez,


this happens when the reference to the instument has not been properly closed.


When this error occurs, select Run Clean UP instead of Abort to make TestStand close the opened references properly.



Message 2 of 8

I still have the Problem. I tried just to run the clean up , but does not work. Could you share how did you solve the issue with me please?

Download All
0 Kudos
Message 3 of 8


I have the same problem, can anyone help with it?

0 Kudos
Message 4 of 8

Did you highlight the Close DMM step in the Cleanup and then run Selected Step. Don’t run the whole sequence. 

Ray Farmer
0 Kudos
Message 5 of 8

Do you have a Soft Front Panel for the device open? Or do you have a test panel in MAX open to the instrument?


If you aborted your TestStand sequence with an open session, it is possible that the resource was leaked. Try restarting LabVIEW and TestStand.


If none of that works, try rebooting the computer. The resource is clearly tied up somewhere, but a reboot is quickest way to recover.


If it does not work after a reboot, then the system is in a really bad state, and you should try working with the device in MAX to verify it functions normally.

- Regards,

0 Kudos
Message 6 of 8


In the setup step of the main sequence, you have initialised DMM, Power supply and Scope. 

Add value for DMM out = FileGlobals.Instruments.DMM

Power Supply out = FileGlobals.Instruments.PowerSupply

Scope out = FileGlobals.Instruments.Scope

Re-run the main sequence, and everything will be OK.

0 Kudos
Message 7 of 8

I got same error , but it is resolved by changing Power supply reference from "PowerSupply" to "Power Supply".

0 Kudos
Message 8 of 8