NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Differences in how subordinate DLLs get loaded between Sequence Editor vs. Custom GUIs

When you write that the UI loads the sequence and executes it, but fails due to some internal error... WHEN exactly does the error occur?

Is it:

a) When you load the sequence file

b) When you start an execution using a model

c) When you start an execution using an interactive execution (e.g. "Run Selected Steps")

d) When your execution hits the first step calling into one of the DLLs (no matter which)

e) When your execution hits the first step calling into one specific DLL (which one then?)

f) When your execution hits the second step calling into one specific DLL

g) When your execution hits a step calling into the second DLL after some other step already executed calling the first DLL

h) When your execution finishes

i) When you close the execution

j) When you unload the sequence file

k) When you shut down the TS Engine (close UI)

 

Please alos check if you modified "load" and "unload" options for steps using the DLLs.

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 11 of 13
(1,136 Views)

When running from the GUI.  The sequence is executed via the "Test UUT's" entry point, same as the sequence editor.  The same load and unload options are used.

The failure occures in my instrumentation inititialization step in my test DLL.  The specific point where the failure occurs is the first call into the Ballard Arinc 708 API DLL from my test DLL.

 

Note when running from the sequence editor.  It isn't just this initial call that works.  All of the calls to Arinc 708 API, and all of the Arinc 708 tests work.  It's also very stable and repeatable, so it isn't something where the first one passes and subsequence attempts fail.  It always works.  Where as with either the custom or example GUIs, every attempt, first, second, all, fail at that same first call into the 708 API.

 

When you write that the UI loads the sequence and executes it, but fails due to some internal error... WHEN exactly does the error occur?

Is it:

a) When you load the sequence file

b) When you start an execution using a model

c) When you start an execution using an interactive execution (e.g. "Run Selected Steps")

d) When your execution hits the first step calling into one of the DLLs (no matter which)

e) When your execution hits the first step calling into one specific DLL (which one then?)

f) When your execution hits the second step calling into one specific DLL

g) When your execution hits a step calling into the second DLL after some other step already executed calling the first DLL

h) When your execution finishes

i) When you close the execution

j) When you unload the sequence file

k) When you shut down the TS Engine (close UI)

 

Please alos check if you modified "load" and "unload" options for steps using the DLLs.

 

Norbert

0 Kudos
Message 12 of 13
(1,125 Views)

Did you also try the default TestStand GUI in Editor mode?

 

I'm asking because i think that issues like this can be created by interim unloading of the DLL. That means that the DLL might lose configuration information.

Does the issue also occur if you restrict the GUI to a single core (use Windows Task Manager to do this)?

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 13 of 13
(1,112 Views)