NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Debugging .NET Assemblies with Visual Studio 2019

New user trying to debug into .NET assemblies with TestStand 2019 and Visual Studio 2019.  The assemblies are built with .NET 4.7.2 and calling Debug (not Release) build.  Have a breakpoint on the TestStand step and when I try stepping into the assembly, I get the following:


The Step Into operation failed for the following reason:

'Failed to step into 'xxx'. Could not find DIA

CLSID for this version of Visual Studio.'


Execution with continue as if you did a Step Over operation.


Any help is appreciated on how to setup environment to debug TestStand and VS 2019.

0 Kudos
Message 1 of 11

I'm using VisualSTudio 2019 (16.5.1) and TestStand 2018.

In my code I use .NET framework 4.6, and debugging works for me fine.


0 Kudos
Message 2 of 11

Thanks for the response.  I'm using 16.5.5 and TestStand 2019.  I updated the assembly to .NET 4.6 and tried again with same "Could not find DIA CLSID for this version of Visual Studio."


One thing that someone else mentioned was checking the Measurement Studio extension.  I noticed it is not showing on the main menu and checking Extensions > Manage Extensions...  the Measurement Studio extension is not found in list.  Also, I noticed the Measurement Studio templates do not show up in the New Project Dialog.  However, I was thinking they wouldn't as it is the new dialog and read changes were needed to get projects to show in this new dialog.


I'm actually new to using .NET with TestStand, so if you don't mind, what steps do you perform in order for TestStand to step into your .NET assemblies?  I put a break point in my code, a break point on my TestStand step, click Execute > Run Selected Steps and once step hits, I click Step Into (F8).  It will pause for a few seconds and then display the error.


I have Test Suite license with Measurement Studio Enterprise.  I tried this on 2 computers with same results so I'm assuming I didn't install/configure something correctly.


Thanks for any help with my issue.

0 Kudos
Message 3 of 11

If I would say I'm experienced, it would not be true.

I have some experience only with custom step panels in .NET built in to the steps pane.

When I connect the Visual Studio in debug mode to the SequenceEditor, I place a breakpoint in the VS code, so when it runs it stops there, not in TestStand.


0 Kudos
Message 4 of 11

You might try running the TestStand version selector and re-running it on the current version.


If that doesn't work, you should still be able to debug by manually attaching to the TestStand process from the visual studio debugger (Debug->Attach to Process menu item in visual studio).


Hope this helps,


0 Kudos
Message 5 of 11

Sadly, that does not appear to work either.

0 Kudos
Message 6 of 11

Are you using the Community Edition of Visual Studio? TestStand integration is not supported with the Community Edition. You can probably still debug by attaching to the TestStand process from the Visual Studio debugger though, assuming Community Edition supports that. If you are are not using Community Edition, what version of Visual Studio are you using?

0 Kudos
Message 7 of 11

VS 2019 (16.5.5) Professional

0 Kudos
Message 8 of 11

I checked and realized it is Version 16.6.0 Professional I'm using.


Also, I tried changing the .NET Adapter Configuration to "Use Visual Studio Professional 2019" in the Version of Visual Studio to Use for Debugging dropdown.  Still same error prompt when trying to step into module.

0 Kudos
Message 9 of 11

Hi all I just wanted to point out the TestStand 2019 does not officially integrate with Visual Studio 2019 as stated in the readme.


However you can still debug .NET code modules called by TestStand with Visual Studio 2019 by attaching Visual Studio as a Debugger to SeqEdit.exe or your User Interface 

Dane S.
Product Support Engineer
National Instruments
0 Kudos
Message 10 of 11