NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Creating exe TestStand interface - problem with rights

Solved!
Go to solution

Hi,
I'm trying to make and exe file out of 'Teststand_interface_VI_.vi'. I found that interface somewhere on the internet. Although when I try to put it into the project and create an exe file after clicking 'build' I got and error that I have not needed rights. I also tried to log in on windows on administrator account.
Error:

Visit the Request Support page at ni.com/ask to learn more about resolving this problem. Use the following information as a reference:

Error 8 occurred at Copy in AB_Engine_Copy_Error_Files.vi->AB_Application.lvclass:Copy_Error_Files.vi->AB_Application.lvclass:Copy_Files.vi->AB_EXE.lvclass:Copy_Files.vi->AB_Build.lvclass:Build.vi->AB_Application.lvclass:Build.vi->AB_EXE.lvclass:Build.vi->AB_Engine_Build.vi->AB_Build_Invoke.vi->AB_Build_Invoke.vi.ProxyCaller

Possible reason(s):

LabVIEW:  File permission error. You do not have the correct permissions for the file.
=========================
NI-488:  DMA hardware error detected.

C:\Program Files (x86)\National Instruments\Shared\LabVIEW Run-Time\2012\errors\CDTest-errors.txt 

 Do you know any solution to it?

 
Files are in the attachemnts.

Michał.

Download All
0 Kudos
Message 1 of 7
(3,915 Views)

The source code for a simple and full operator interface are installed with TestStand. Have you opened either of these projects and tried doing a build?

0 Kudos
Message 2 of 7
(3,905 Views)

Hi thor91,

 

Try adding also the llb into the same project with the VI. I am refering to TestExec.llb.

 

Best regards,
IR.

0 Kudos
Message 3 of 7
(3,819 Views)

IonR, I've added the TestExec.llb file and  I keep getting the same error message.

0 Kudos
Message 4 of 7
(3,814 Views)
Solution
Accepted by thor91

Hi thor91,

 

Have you tried to launch LabVIEW with admin rights? I mean, right click and run as administrator? 

I  have tested multiple times th VI and llb uploaded by you on this forum and it worked fine for me to compile it to an executable.

If it still doesn't work, please write what version of software you are using, what type of licenses you are using, to understand in depth where is the problem.

 

Best regards,

IR

Message 5 of 7
(3,810 Views)

Running as administrator did not help. I use labview 2012 SP1 and I got license from the university. 
This is the error I get: http://i79.photobucket.com/albums/j122/thor_tory/1_zps45b62c92.png~original

And here is the source of the interface i want to add to project:

http://www.ni.com/example/31278/en/ (all I need is executable file)

Michał.

@edit: perhaps you can send me just exe file and I'll add it to my system. 

0 Kudos
Message 6 of 7
(3,807 Views)

Michal,

 

The Error 8 you're seeing is sometimes caused by issues with file permissions, or if a file is currently open. You might want to check and make sure none of the files are read-only and that your Windows user has permissions for the directory you're placing the built application in. As a troubleshooting step, I would also suggest setting the build location to a different directory to eliminate that as a possibility.

 

Finally, as Dennis mentioned previously, could you try doing a build of one of the built-in interfaces? It's always helpful for us to make sure you can build a separate application, to narrow down whether this is related to your custom interface code or something with the overall machine configuration.

 

Let us know how it goes!

Daniel E.
TestStand Staff Product Support Engineer
National Instruments
CTA/CLD
0 Kudos
Message 7 of 7
(3,775 Views)