NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Could not find DIA CLSID for this version of Visual Studio

Highlighted

Hi,

I'm trying to debug .NET dll from TestStand 4.2.1. I do have installed VS 2010 and Measurement Studio 2010 (Evaluation). I do receive warning :  Could not find DIA CLSID for this version of Visual Studio.

 

Do I need Measurement Studio 2010 Enterprise , what is difference between Enterprise and just studio?

 

Any other suggestions ?

 

P.S. As searching on web I found suggestion to register  msdia100.dll , after that I received a warning: "Catastrophic failure" while trying to step into dll ... Robot surprised

 

Regards,

Jan

0 Kudos
Message 1 of 4
(1,988 Views)
Highlighted

Hi Jan,

 

Unfortunately trying to step into your DLL from TestStand 4.2.1 using VS 2010 is not going to work.  You should be able to do this using either VS 2005 or VS 2008.  TS 2010 is the first version of TS that officially supports VS 2010.

 

That being said, you should be able to do the following to debug your DLL using VS 2010.

1) Open up the solution for your DLL in VS 2010.

2) Set a breakpoint inside the method you wish to debug.

3) Attach the VS 2010 debugger to the TS 4.2.1 sequence editor (or UI that you are using).

 -You can do this by selecting Tools->Attach to Process

 -You may also want to specify what types of code you wish to debug (Managed 2.0 is likely what you want assuming your DLL is not built against .NET 4.0)

4) Run your sequence in TS, and when the step executes that calls the method in which you set your breakpoint, VS should break at it.

 

Hope this helps!

 

-Jeff

0 Kudos
Message 2 of 4
(1,978 Views)
Highlighted

Thanks for quick answer, it seems to be working!

 

Jan

0 Kudos
Message 3 of 4
(1,949 Views)
Highlighted

Hello,

 

I tried the different steps listed above and I still get the same error. I'm using TestSand 4.2.1 and VS 2010 Professional. When I attach VS to TestSand Process it gets the "Running" under VS, but after running my sequence in TestSand it always gets back with the error message. I tried setting the code type to Managed 2.0, Managed 4.0 or Native Code and it does not work. I tried attaching the process after my TestSand sequence runs and same error. Any thoughts? What does CLSID stand for?

0 Kudos
Message 4 of 4
(232 Views)