NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Could not connect to TSAutoMgr.exe and error 17501

Hi,

 

I'm running TS3.5 on Win 2000 system.

 

I'm experiencing the above error (also see attached screen shots in pdf file).

 

The error message is talking about DCOM configuration.  

 

I verified that I have the TSAutomgr.exe file.

 

I execute the utility dcomcnfg.exe but I can't find the TSAutomgr.exe there....

 

where exactly TSAutoMgr.exe should be listed?

What does it mean if it's not there?

 

And advice what to do next?

 

Thanks

Rafi

0 Kudos
Message 1 of 7
(3,039 Views)

Here's a better screen shot.

 

Also be noted that after this error the TestStand boots up.  But when i run my application I get another error associated with labview.  I assum that it is related to the first problem...

 

Thanks

Rafi

0 Kudos
Message 2 of 7
(3,037 Views)

Sorry,

 

Here's the screen shtos

0 Kudos
Message 3 of 7
(3,036 Views)

Hi Rafi2003,

 

This error occurs when the TestStand CVI adapter fails to connect to the TestStand AutoMgr COM server.  Usually this is caused by a problem with the DCOM permissions associated with this server. I would follow the steps in this document first.  This should take care if it for you.  If not, I would look under the security tab of the NI TestStand AutoMgr Properties box. Here I would like you to verify that you have Local Launch, Local Activation and Local Access permissions. If the Use Default radio button is checked, then you'll need to verify that the default permissions for the computer are set appropriately. Finally, even if permissions are granted specifically by the server settings, you still need to verify that the computer doesn't set limits on applications that set their own permissions. You can edit the computer-wide defaults and limits on the COM Security page of the Properties dialog of My Computer in the Component Services tool.  

Cheers,
Kelly R.
Applications Engineer
National Instruments
0 Kudos
Message 4 of 7
(3,001 Views)

Hi Kelly and thanks for your help.

 

1)  My first problem is that I don't see the TSAutoMgr DCOM!!!

 

     Under   Components Services-->Computers-->My Computer  I only have the following:

           COM+ Applications

           Distributed Transactions Coordinator

 

           Where is the DCOM directory?  How can I make it appear?

 

2)  I'm trying to follow your instructions regarding editing the computer-wide defaults.

      Under the   Components Services-->Computers-->My Computer-->Properties I have the following options:

            Default Properties (Enable Distributed COM is checked)

            Default Security

                  Default Access Permissions  (non is listed)

                  Default Launch Permissions  (3 items listed, all have allow DefaultLaunchPermission)

                  General

                  Options

                  MSDTC 

      I believe you instructions are for WinXP, whereas I'm using WIN2000.

      Where are the limits editing for WIN2000?

 

 

Thanks

Rafi

                  

0 Kudos
Message 5 of 7
(2,984 Views)

Hi Rafi,

 

That is interesting.  If you go to the Default Properties page, you said "Enable Distributed COM on this computer" is checked, correct?  If you make a change to this option you do need to restart for this change to take affect.   If you are still not seeing this, would it be possible for you to take a screenshot of the what you see when you try to navigate to DCOM as well as this options box.

 

Also, it sounds like Default Security is analogous to COM Security on my XP machine.   I have the option for Access Permissions and Launch and Activation Permissions, and to edit both of these. 

Cheers,
Kelly R.
Applications Engineer
National Instruments
0 Kudos
Message 6 of 7
(2,963 Views)

Hey Rafi

 

I had a similar issue today and I was able to fix it by repairing TestStand. Go to Start>>Control Panel >>Add or Remove Programs>>National Instruments Software and then choose the repair option for Teststand. See if that works for you.

Regards,
Efrain G.
National Instruments
Visit http://www.ni.com/gettingstarted/ for step-by-step help in setting up your system.
Message 7 of 7
(2,415 Views)