NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Cluster of Boolean Controls not updating in TestStand

Solved!
Go to solution
Highlighted

Hello All, 

 

I have a Labview vI which I am calling in TS. Because there are many boolean controls I packed allthe bools in clusters and assigned a default value to some of them. Before I called my VI, I have an fx statement file where I also assign some boolean controls a new value, then I call this VI. I realized that the VI loads but the new value is not written to my hardware.

Attached you will see the block Diagram, the fx statement file and the TS Sequence where I call the VI. 

Does anyone know why these values are not updated when I call them in TS. 

I have tried this in a Test VI where I start my programme and press the boolean buttons and my HW shows a signal for the Bool pressed button. 

 

TS and Labview / 2017

 

Thanks for your assistance. 

 

BR

0 Kudos
Message 1 of 5
(301 Views)

Hello iWin,

 

1) How does your VI works if you remove the TestStand API part ?

2) Does this write the value into your hardware ?

 

3) I'm not sure what you are doing with the TST API in your VI, could you describe its goal ?

You seem to read a value from TST, but you don't do anything with it.

 

4) Have you tried to debug your VI to see if the value are present in the wires ?

 

Regards,

 

0 Kudos
Message 2 of 5
(164 Views)

Hello Salah_I,

 

Please find the answers to your questions.

 

1. The VI is called in TS and the API has not influence. I already observed the reactions from the clusters before I added the TS API. The API is used to stop the while loop at the end of my sequence run

2. No, that is why there are no changes.

3. See answer 1

4. Yes the Values are present in the wires.

Regards

0 Kudos
Message 3 of 5
(143 Views)

Have you tried stepping into your VI and step through your VI.

is your front panel showing your inputs?

are they passing through your code ok?

is they any errors?

 

 

Regards
Ray Farmer
0 Kudos
Message 4 of 5
(121 Views)
Solution
Accepted by topic author iWin

Hello All,

 

I have tried the methods you mentioned in your post before opening the online post support.

I have been informed by the Project Manager that there is a mistake in our document ;(.

The values / bits I am trying to set through my Prog. are now handled internally on the new product SW and any value changes from the ext.SW will be ignored which explains why these buttons are not reacting as expected even though the values are properly sent and written to the Bus.

I appreciate your answers and contributions and will mark this as solved.

 

Regards

 

 

0 Kudos
Message 5 of 5
(100 Views)