NI TestStand

Showing results for 
Search instead for 
Did you mean: 

BuildTSD.exe Won't Run Headless

Go to solution



I've been using TestStand 2016 with Atlassian Bamboo for a few years now to do automated builds without any issues.


However, I've recently upgraded to TestStand 2019 x64 as am also quite a bit Python user so wanted to use the Python step types, and have discovered that I now have to be logged into the Build Server via remote desktop for the build to work, with the symptoms if I don't being that the build just hangs and is eventually terminated by the build agent with no error messages provided.


I've tried all of the usual tricks i.e. setting programs to run as Administrator, but to no avail.


Has anyone else seen this, or has anyone got any suggestions for things I can try to fix this?

Thanks in advance for any help.

David Clark
IDEX Biometrics UK Ltd
Hampshire, England
0 Kudos
Message 1 of 4
Accepted by topic author davidpcl

Can you check the DCOM settings for TSAutoMgr and make sure it's set to 'Launching user'?

  1. Open the Run Window (Win + R).
  2. Type dcomcnfg and press enter.
  3. Navigate to Component Services»Computers»My Computer»DCOM Config»NI TestStand AutoMgr.
  4. Right click NI TestStand AutoMgr and select Properties.
  5. In the Identity tab, change the user account to The launching user.

If you had been using TestStand 2016 SP1 specifically in the past, you never would have had to do this because of known issue 666537 where that default property was changed for that specific version.


Hope this helps!

0 Kudos
Message 2 of 4
Accepted by topic author davidpcl

Hi Trent,


That has fixed it - thank you so much for help! You've very much made my day.

Best regards,


David Clark
IDEX Biometrics UK Ltd
Hampshire, England
Message 3 of 4

How are you running teststand sequences from Bamboo.  I am trying to use a Bamboo "script" step to run my command, Bamboo seems happy but teststand is not doing anything.  My sequence should just be writing timestamps to a file and nothing happens.  It works fine if I run it directly from a command line.

0 Kudos
Message 4 of 4