NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Build Error cannot find the distribution being built

Go to solution

I  have been having a similar issue as this thread.


 My installer keeps asking for and old copy of the installation as it is finishing up. Quite annoying as it takes so long to get there. Any advise would be appreciated. I have attached a screen shot of my error message.

0 Kudos
Message 1 of 6

Hello Satguy,


Have you tried to build the distribution after changing the destination directory to something other than the source?




Jeff L.

0 Kudos
Message 2 of 6

Yes. I have tried changing destination as well as the TSD file location. I have tried many things. Keep in mind this has worked in the past many times as this is an ongoing long term project. So far the best two suggestions I have heard is rebuild the TSD from scratch and complete reinstall of NI. I will try the TSD rebuild first...


I will certainly report the fix when I finally have it. If anyone else has specificic experience with this type of issue I certainly would appreciate some pointers on how they dealt with it.

0 Kudos
Message 3 of 6
Accepted by Satguy

You've created this problem by running a previously build installer on your development machine. If you're distributing drivers with your installer you should NEVER run the installer on the machine you build it on.


Here's what is happening:


All NI software stores where it was installed from in the Windows Registry. When you installed it originally it noted where you installed it from (DVD, Network drive, etc.)


When you build an installer in TestStand it prompts you for that location if it cannot find the original installation files (i.e. if you've taken the DVD out of the drive, disconnected the PC from the network, etc.)


What happened on this PC is that you've build an installer, then you ran that installer on the PC and since the drivers were already present it overwrote the path that is stored in the Registry with the path of where your installer was located (e.g. C:\Temp\long path)


I'm guessing you've now deleted that old installer. Which means that you need to re-run the installers for ALL the NI software you have installed on that machine so that the registry gets updated to point back to the DVD path or network path.

Message 4 of 6

Excelent Answer. Yes a while back I did run an installer on this Machine. I will try a re-install and post result.


FYI I had a seperate build machine that currently is down due to HD crash. This is why it was undiscovered until now.

0 Kudos
Message 5 of 6

Just to follow up on the solution... Reinstall LV/TS did not fix issue. uninstalling all NI and reinstalling fixed issue and I am able to create Builds again on this PXI Controller.


Take away... never install a distribution on your source machine!


Thanks for the help.

0 Kudos
Message 6 of 6