NI TestStand

Showing results for 
Search instead for 
Did you mean: 

Asynchronous VI interfering with Message Popups intermittently



I've found an issue with something I haven't encountered before.  I have an asynchronous VI running in a corner of my screen providing 5 pieces of information (spelled out a little below).  A problem occurs, intermittently, and not at the same step; what I've seen happen quite a few times now, is that when a TestStand message popup is called, it will not let me select one of the buttons from the popup.  What I end up doing to continue on is to abort the asynchronous VI (press abort button) and TestStand goes through an error cleanup with that, the popup goes away, then the sequence continues running.  The sequence acts like the message popup was closed, and continues on. 


The Asynchronous VI uses the context of the calling thread.  It's running constantly and displaying 5 measurements/pieces of information.  There are 2 USB devices I am read from using VISA, I have another device I'm communicating with over RS232, I am checking the status of a general purpose relay in a NI 9401 module sitting in a cDAQ-9174, I am reading a voltage from a NI 9215 sitting in the same cDAQ-9174.  I am scanning the execution status of the current context to look for a terminate/abort.  I am also scanning a parameter, using it as a stop boolean, if it's true I stop the asynchronous VI, if it's false, I keep it running.


I've set the priority of the VI to lowest (and others to test) and still see the problem, I'm using a Preferred execution system of, "same as caller".  In the window appearance setting, I have the window behavior set to, "Default", I'm going to test switching it to floating, I don't want it to be modal.


These are the things I can think of that I've tried to solve this weird intermittent issue.


I guess I'm not sure what could be causing this, I'm not a real low level TestStand or windows user, so would any of the NI community have an inkling as to what could be causing my issue?









John 3:16
0 Kudos
Message 1 of 2

Just to bump this a bit, I've continued researching the problem, playing with things like the "Preferred Execution System", but unless I'm incorrect, this pertains to other LabVIEW VIs, not the TestStand message yes, switching to multiple different execution systems did not solve the issue.


One new piece of information is that the TestStand message popup will remember which button I last tried to select before I abort the asynchronous VI.  So if I click button 3 of the message popup, nothing happens, TestStand does not continue forward until I abort the asynch VI.  The curious bit is that the sequence remembers I selected button 3 and goes down that case.  I did not notice this before, but today I've been working on a section where a message popup controls a select statement.


Anyway, still digging if anyone's got any clues.



John 3:16
0 Kudos
Message 2 of 2