NI Package Manager (NIPM)

cancel
Showing results for 
Search instead for 
Did you mean: 

Package Manager fails to uninstall NI PXI Platform Services

I'm trying to uninstall NI stuff and Package Manager runs into an error.

 

===== 2020-Jun-18 12:39:44.007776 =====
Exception in ni::pkgclient::TransactionBase::StartInternal. Error code: -125084
Request type: 30
-125084: An error occurred while removing a package: a0865ca8-e3fc-4fa2-ae33-3b027dafff94 (3.21.49152)
File: source\nipkg_client\pkgclient\PluginInteraction.cpp
Line number: 238

Additional error information:
-125531: An error occurred while uninstalling the MSI at '-IsCore-pxiPlatformServices.msi'. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.
File: C:\dev\23\s\nipkg\source\shared_agents\WinInstall/ErrorHandler/ErrorInfo.h
Line number: 131

 

How do I fix the problem?

0 Kudos
Message 1 of 5
(763 Views)

A little bit more details. Here is what package manager thinks of this package:

PS D:\Program Files\National Instruments\NI Package Manager> .\nipkg.exe info-installed a0865ca8-e3fc-4fa2-ae33-3b027daf
ff94
Architecture: windows_all
Depends: 5b0cb826-e499-4e6b-94f0-75b6327ed934, 2146bd10-9fc7-44aa-89a3-9ddda44525a7 (>= 3.00.0), c3b27671-335d-4816-b189
-3eac7e5db5e7 (>= 3.21.49152), 70dd7dd2-1f72-43ba-b7be-30d2104e7e37 (>= 1.62.0), 650d3e7a-1658-4751-90b9-d1140c018748 (>
= 2.30.0), 74cd996e-746d-4a5e-b7d9-4ed5fbafcf0d (>= 3.21.49152), 742c82ad-223a-4cce-afec-55d0c1a659e7 (>= 2.20.0), 422ed
ffd-8b84-4544-aa76-73ac3492d525 (>= 8.05.0), fda3f8bb-baa9-45d7-8dc7-22e1f5c76315 (>= 9.0.401), e149cd72-c9c6-11d3-aad5-
00104b6ce75a (>= 10.101.0), 5aabd17a-8f56-4204-b076-214768016537 (>= 3.00.0), a35e92e7-dff5-4c31-8fed-f1635f19666c (>= 3
.21.49152), be400a3d-e9d6-48d9-af14-337722a11d40, 1f2c1e66-64c0-4ce1-b96e-7bb6ec99fcb1 (>= 1.03.0), bbc3e40f-e55f-469d-8
1f3-9963ecd350fa (>= 3.00.0)
Description: This is required for NI software.
DisplayName: NI PXI Platform Services 3.2.1
InstalledBy: WinMIF
Maintainer: National Instruments <support@ni.com>
MsiProperties: UC={A0865CA8-E3FC-4FA2-AE33-3B027DAFFF94}:PC={D32A5F70-671C-4790-A7EC-BE288485CFEC}:PV=3.21.49152
Package: a0865ca8-e3fc-4fa2-ae33-3b027dafff94
Plugin: wininst
Provides: a0865ca8-e3fc-4fa2-ae33-3b027dafff94 (= 3.21.49152)
Section: Other Software
UserVisible: yes
Version: 3.21.49152
WinInstType: legacy

0 Kudos
Message 2 of 5
(696 Views)

Here is what package manager tells me if I try to remove the package:

 

PS D:\Program Files\National Instruments\NI Package Manager> .\nipkg.exe remove PACKAGES a0865ca8-e3fc-4fa2-ae33-3b027dafff94
PACKAGES is not installed.
The following packages will be removed:
a0865ca8-e3fc-4fa2-ae33-3b027dafff94, a35e92e7-dff5-4c31-8fed-f1635f19666c
Installing 0 package(s); Upgrading 0 package(s); Removing 2 package(s); Downgrading 0 package(s)
Need to get 0 bytes of archives.
After this operation, 0 bytes of additional disk space will be used.
Do you want to continue? [y/n] y
Removing a0865ca8-e3fc-4fa2-ae33-3b027dafff94: Done
Error -125084: An error occurred while removing a package: a0865ca8-e3fc-4fa2-ae33-3b027dafff94 (3.21.49152)

Additional error information:
Error -125531: An error occurred while uninstalling the MSI at '-IsCore-pxiPlatformServices.msi'. There is a problem with this Windows Installer package. A program run as part
of the setup did not finish as expected. Contact your support personnel or package vendor.

0 Kudos
Message 3 of 5
(695 Views)

Hi Yakov,

 

I am sorry to see no one has been able to provide information or a solution in the last 7 months since you posted this.
I have a similar problem while installing LabVIEW 2020 SP1 (64-bit) on a Windows 7 Professional SP1 (64-bit).

Details from NI Package Manager Logs > errorlog.txt

Additional error information:

-125531: An error occurred while uninstalling the MSI at '-IsCore-DotNet461.msi'.

 

Strange though, I have already installed it successfully on two other computers with the same System and edition of Windows!

Please let me know if you found out more about this since posting?

Thanks,
Paul

 

0 Kudos
Message 4 of 5
(242 Views)

Here's some more information about my issue and the solution - maybe it will help others with similar problems.

So the original error, while installing LabVIEW 2020, occurred when the installer was "Removing NI .NET Framework 4.6".

(Don't ask me why there is a problem with .NET Framework, as NIPM had just installed .NET 4.6.2 before doing anything else!?)
Also, the NIPM error log refers to "-IsCore-DotNet461.msi"
So, using NIPM, we did a "REPAIR" on all components relating to .NET.

This cleared the problem.

 

 

0 Kudos
Message 5 of 5
(220 Views)