NI Package Manager (NIPM)

cancel
Showing results for 
Search instead for 
Did you mean: 

Error while upgrading NIPM, stuck at version 18.5 now forever.

Solved!
Go to solution

I was trying to install DAQmx v19 via NIPM but told the version is too old to do so. Hence, I tried to update my NIPM (v18.5) to the latest. However, I keep getting this error while updating the NIPM. This error also prevent me from uninstalling any of the NI software I've already installed. What is the problem? Thanks.

NIPM.JPG

0 Kudos
Message 1 of 6
(247 Views)

Have you tried install the latest NI Package Manager via the offline download? (The link is in the lower right side of the page and currently the latest is 19.6)

__________________________________
Bill Eisenhower
Certified LabVIEW & TestStand Developer
0 Kudos
Message 2 of 6
(189 Views)
Solution
Accepted by GJ.VVU

If you are still facing the same issue even after using the latest NIPM offline installer, then please enable MSI logging as mentioned in the below KB, try upgrading NIPM once again to generate that error and please share the logs so that we can investigate further:
Generating and Locating NI Package Manager Error Logs

0 Kudos
Message 3 of 6
(156 Views)

Yes, I did try to use offline installer, it gave me the same error.

0 Kudos
Message 4 of 6
(136 Views)

Hi,

 

I've tried the solution you've provided to log the error, magically, after I enable the MSI log, the offline installer is able to install the latest NIPM successfully. It was very weird that it behaves like this. Enabling the MSI error log made the install successful?! I will note down the solution. Thank you. 

0 Kudos
Message 5 of 6
(135 Views)
Highlighted

Glad that it worked, but it is odd that enabling the MSI log had this effect, and isn't what we'd normally expect. However, the Windows Installer engine (MSI) is part of the Windows OS, so it's possible that timing or something else happened to fix it. But, since it completed successfully, you can be confident that it is installed correctly. Do be sure to disable the MSI logging, as it does negatively affect performance.

0 Kudos
Message 6 of 6
(132 Views)