NI Package Manager (NIPM)

cancel
Showing results for 
Search instead for 
Did you mean: 

Building NI Packages for older versions of NI Package Manager

I'm making an update to a package I've made in the past and I'm trying to deploy it to my one of my systems. I'm running into an issue with deploying with this error message:

 

errors:
- Error -125081: Package 'my-package' requires a newer version of Package Manager. To update, navigate to the Package Manager UPDATES tab and update the NI Package Manager package. After updating, retry this transaction. (Compatibility value 200601 is less than package value 200702.)
"

 

I'm in a position where I can't update the Package Manager (It's a long story, but it's not doable). Is there a way in NI Package Builder where I can build new packages targeting older versions of Package Manager? 

0 Kudos
Message 1 of 2
(96 Views)

The system you build the NI package with will need to have the version of NIPM you want it to be installable with. It appears that the version of NIPM installed is used/listed at the minimal required version. You can find older versions of NIPM from the download pages offline installers link.

__________________________________
Bill Eisenhower
Certified LabVIEW & TestStand Developer
0 Kudos
Message 2 of 2
(53 Views)