NI Package Manager (NIPM)

Showing results for 
Search instead for 
Did you mean: 

Browse Products tab gone after update

Go to solution

Hi all,


I just updated NIPM and after the update, it told me that the Browse Product link is no longer displayed and I should look for my packages online. Is this a bug or the new functionality?

I found my packages online, but the interface is far less convenient than NI Package Manager itself. Did this happen to anyone else?

Remember Cunningham's Law
0 Kudos
Message 1 of 52

What version of NIPM did you update to? 20.6?

Bill Eisenhower
Certified LabVIEW & TestStand Developer
0 Kudos
Message 2 of 52

Yes, exactly


Remember Cunningham's Law
0 Kudos
Message 3 of 52

I know very painful! NI please restore this

Message 4 of 52
Accepted by PeterFoerster

This is not a bug, this is a feature!




I don't get why they removed the one thing that was actually good on this whole transition to NI Package Manager. The website has been a complete mess for a couple of years, so the product page on the NIPM was a very nice feature. finally a central place with all the software available.

Message 5 of 52

I saw that message. I just hoped I was hallucinating.


It would be interesting to hear what the motivation is behind removing this feature. For me at least it has always worked very well.

Remember Cunningham's Law
0 Kudos
Message 6 of 52

So this is this "ambitious engineering"? To me it seems to be simple laziness...


Please revert it.

Michał Bieńkowski

Someone devote his time to help solve your problem? Appreciate it and give kudos. Problem solved? Accept as a solution so that others can find it faster in the future.
Make a contribution to the development of TestStand - vote on TestStand Idea Exchange.
Message 7 of 52

Hi All,


We work in a company that has very heavy restrictions on software policy and put up many barriers to people installing or running executables in our organisation. Having spent time with the NI Package Manager developers we came up with a solution that we have deployed at our company that allows us to run the package manager with special elevated rights that are invisible to the user, which would in turn allow a non-admin user to install standard NI software from the nice (and intuitive) package manager interface.


Removing the browse products tab has fundamentally broken our process and has pushed us back to our original problem as all products now download as bare executables which require individual administrator rights to run.


I would love some clarification from NI as to why this decision was made. I would also love some alternative solutions to our issue now as NI was fully aware of our situation when they decided to do this "upgrade".


There are no positive impacts this change has that I can see... (other than getting website more traffic)


Kind Regards,



Larry Colvin
Associate Principal Engineer
Dyson Technology Ltd.

Message 8 of 52

We have the same problem.
Our production network/PC can't access and browse the internet.
But we've configured so the NI Package manager could download and install stuff e.g. LV Run-Time engines that is needed an all rigs, but that won't work anymore

0 Kudos
Message 9 of 52

An Idea to help improve the new website based experience.

Bill Eisenhower
Certified LabVIEW & TestStand Developer
0 Kudos
Message 10 of 52