NI Linux Real-Time Discussions

Showing results for 
Search instead for 
Did you mean: 

network drive automount help.

Hi,  I tried mounting a network drive in a shell and it worked :  mount -t cifs //$ /mnt/photo -o username=username,password=password,domain=domain  However I want to automount it at boot up. I read that I have to enter it in /etc/fstab file.  I entered like this :   //$ /mnt/photo cifs username=username,password=password,domaine=domain  It does not work, I also try other thing like :   //servername/sharename  /media/windowsshare  cifs  username=msusername,password=mspassword,iocharset=utf8,sec=ntlm  0  0  still not chance...  I'm using the good servername, username and password.  Thanks for your help.  Patrick

0 Kudos
Message 1 of 4

Hi Patrick,

What versoin of the OS are you using?

If the command that you listed running from the commandline works correctly, then I think all that needs to be done is to reenable the network filesystem mounting script (/etc/init.d/ The initscripts are started or stopped based on their listed priorities, be sure to read up on one of the good articles on iniscripts, be sure to read one that targets sysvinit, not one of the other init systems (like systemd or openrc). Basically, you need to be sure that the script starts after networking is already up and stopped prior to networking being brought down.

Let us know if you need some more details or resources

0 Kudos
Message 2 of 4

I will read on that tomorrow. Thank you.

I'm using an Industrial Controller IC 3173 that run Real Time Linux 64 bit.

0 Kudos
Message 3 of 4

I've read a bit and didn't undestand exactly.

What I undestand was to put the somewhere in the rc(N).d folder after S01networking and adding a prefix of exemple to the file.

Didn't working like this in rc3.d


anytime I have network on the controller, I do mount -a and my network drive mount fine! I'm just not able to do it at startup.


There is rc0.d (1, 2, 3, 4, 5 6, S)


If you can help that would be great.

0 Kudos
Message 4 of 4