NI Linux Real-Time Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Installation of NI Linux RT system image fails

Solved!
Go to solution
Highlighted

The installation of the NI Linux RT system image fails on our new PXIe-8861.

System_image_error.PNG

 

 

 

 

 

 

 

 

 

 

 

 

 

We don´t see any reason for this behaviour. Eventually someone coul help. many thanks in advance

0 Kudos
Message 1 of 8
(462 Views)
Highlighted

This error indicates a problem extracting files into place on the target filesystem. Please attach a display and usb keyboard to the PXIe-8861. Log in as user admin. The password should be blank at this point. At the shell prompt try the following commands to provide more detail.

# nisafemodeversion
# df -h
# ls -l /tmp/*
# tail /etc/natinst/share/log/installationStatus.log

If /etc/natinst/share/log/installationStatus.log does not exist, try tail /tmp/installationStatus.log instead.

 

What that shows us may point to a specific /tmp/install_*.log that will contain further information about the source of the failure. 

0 Kudos
Message 2 of 8
(408 Views)
Highlighted

Dear jwp200, thanks for your answer. However we don´t get a result of the "tail" command. Here is the screen:

PXIe-8861_screen_1.jpg

0 Kudos
Message 3 of 8
(381 Views)
Highlighted

Can you do the following:

 

1. Format the controller.

2. Attempt to install software.

3. Check to see if the installationStatus.log file now exists.

 

I tried this on a Linux target where the log file was missing and it has now been created. Not sure what removed it, as this is a target that gets reformatted regularly.

 

Can you confirm which version of LV you are using? 

 

Personally I use FilleZilla to navigate the file system (enable sshd) as it allows me to download files more easily.

 

David Corney
0 Kudos
Message 4 of 8
(364 Views)
Highlighted

Siliconworker, thanks for running those commands and providing the results.

 

The /tmp contents indicates the target has been rebooted since the original failure you reported since no logs were present. Please reproduce the problem again as AustinManinTown suggested and then follow my same instructions as before. Make sure the keyboard and display are attached to the PXI prior to performing the installation from MAX

 

DO NOT enable SSH after the failure as was suggested by AustinManinTown, at least not from MAX. If you enable SSH on the target from MAX it will reboot the target and again the logs in /tmp that might have helped will be lost. If needed I can tell you how to enable SSH from the console without rebooting the target.

Message 5 of 8
(352 Views)
Highlighted

Dear AustinManinTown and JWP2000, thanks for further hints. After that I have found the "installationStatus.log" in two folders. Please see the screen photo, which lists also the file content.

PXIe-8861_screen_2.jpg

0 Kudos
Message 6 of 8
(334 Views)
Highlighted
Solution
Accepted by topic author Siliconworker

Many thanks for your support. The problem has been solved by installation from another PC with very similar configuration (OS and LV). However we don´t see any reason, why the first PC caused the reported error.

0 Kudos
Message 7 of 8
(297 Views)
Highlighted
Solution
Accepted by topic author Siliconworker

The problem was caused by an additional ethernet PCI-card with "Realtek PCI GBE Family Controller" hardware and two different drivers found in Windows 10 or by online search. Now the RT-system runs with a Logilink ethernet USB-adapter without any difficulties.

0 Kudos
Message 8 of 8
(244 Views)