NI Linux Real-Time Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot disable usb-storage or access bios

Highlighted

I've been attempting to disable usb-storage and I've tried several of the common methods but always mounts. Is modprobe.d being bypassed as commands in there seem to have no impact after reboot.

 

Also I'm using a crio 9032 and when attempting to boot to the bios via pressing either f10 or del it gets a software error on bootup and led 2 flashes continuously. 

 

Anyone have experience with either of these issues?

0 Kudos
Message 1 of 4
(191 Views)
Highlighted

The auto-mount behavior for USB storage devices is controlled by udev scripts under /etc/udev/

Specifically you can black list a type of device in '/etc/udev/mount.blacklist' or edit the udev automount rule in '/etc/udev/rules.d/automount.rules' or the mount script '/etc/udev/scripts/mount.sh'.

 

There are options to disable the USB subsystem entirely (via the kernel command line) but that's a bit more invasive.

Message 2 of 4
(148 Views)
Highlighted

I attempted to edit  the mount.sh script and I commented out the statements revolving around umount however it is still mounting usb-storage. Is there a way to end if it is a particular driver name?

0 Kudos
Message 3 of 4
(145 Views)
Highlighted

Maybe override the udev rule?

0 Kudos
Message 4 of 4
(103 Views)