NI Labs Toolkits

cancel
Showing results for 
Search instead for 
Did you mean: 

CompactRIO Hardware Migration Wizard for LabVIEW 2010 SP1

CompactRIO Hardware Migration Wizard

The CompactRIO Hardware Migration Wizard easily adapts CompactRIO applications to new hardware. The wizard launches from the right-click menu of a CompactRIO Real-Time target in your LabVIEW project and guides you through choosing new hardware and configuring project modules.


rightclick.png

When you click Finish, the wizard creates a new project that references your existing VIs and targets them to new CompactRIO hardware. You may still need to recompile your FPGA VIs to run on the new target.

firstframe.png

Note: The wizard works with both FPGA Interface and Scan Interface modes.


Requirements:

  • LabVIEW 2010 SP1
  • LabVIEW FPGA 2010 SP1
  • LabVIEW Real-Time 2010 SP1
  • NI-RIO 3.61 or later
Andy Milluzzi

Rose-Hulman Institute of Technology
University of Florida
Computer and Software Engineering
Comments
Active Participant
Active Participant
on

This looks interesting.  It can be extremely useful when starting from reference designs such as the cRIO vibration data logger: 

http://zone.ni.com/devzone/cda/epd/p/id/6388

I have not tried it, yet will soon. 

Preston Johnson
Solutions Manager, Industrial IoT: Condition Monitoring and Predictive Analytics
cbt
512 431 2371
preston.johnson@cbtechinc
Trusted Enthusiast
Trusted Enthusiast
on

Is there a LabVIEW 2011 version planned?

Kind Regards,
Thierry C - CLA, CTA - Staff R&D Engineer, RF Semiconductor Test - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
Member
Member
on

exactly what I am trying to do.  I want to use cRIO vibration data logger with different hardware.  However, I'm using LabVIEW 2011 so it doesn't work.  This tool would save me so much effort!

Member
Member
on

when are we having this feature installed with LabVIEW?

Certified LabVIEW Developer (CLD)
Certified TestStand Developer (CTD)
Using LabVIEW 8.5.1 (2008) to LabVIEW 2016
Active Participant
Active Participant
on

Is there any chance  that you can update this for later versions of LabVIEW or else make the VIs availabel that went into it so we can do the update ourselves?

Contributors