NI Labs Discussions

Showing results for 
Search instead for 
Did you mean: 

NI VeriStand Custom Device Project Wizard Feedback

Hey Peiyang,


Can you be more specific? How did it fail? What errors did you get? Can you attach screenshots of the errors and messages you see?


The wizard is intended to be used with, and technically only supported for, LabVIEW 32-bit, so it should work. Thanks! --Ryan_S

0 Kudos
Message 11 of 22

Hi Ryan,

After installing project wizard in 64 bit, I try to either downgrade or uninstall the wizard. After doing this, the FPGA module and the real time module are removed.




0 Kudos
Message 12 of 22

Your system state is recap:


1. This wizard is not intended to be used with LabVIEW 64-bit since VeriStand is a 32-bit application. Any functionality with LabVIEW 64-bit has not been tested and I cannot provide guidance on.

2. From your second picture, it looks like you DO in fact have the wizard installed for 32-bit LabVIEW. Run the wizard there and it should work fine.


If you're still having problems, do you have another computer, with only 32-bit LabVIEW that you can test installing and using the wizard on? That might tell you more, and I'm worried you're mixing up your LabVIEW versions when testing...


Good Luck! --Ryan

0 Kudos
Message 13 of 22

Hi Ryan,

I will try to install LabVIEW 2015 SP1 to another computer to see if I get the same issue. I will get back to you once I have done that. Thanks for the advice!



0 Kudos
Message 14 of 22

Hi Ryan,

I installed LabVIEW 2015 SP1 on another computer and tried the project wizard. Linux platform does not appear under my newly built project. It seems to me that exact same issue occurred to this computer as well.




0 Kudos
Message 15 of 22

That's interesting, I haven't been able to reproduce this on my end. A couple questions:


1. Can you attach a MAX technical report from this new computer?

2. What OS is the new computer running?

3. What language is the OS using?



0 Kudos
Message 16 of 22

Hi Ryan,


I seem tripping at the first hurdle, where do I find the download for your "NI VeriStand Custom Device Project Wizard"? I cannot locate it anywhere on or in JKI package manager.


No links to download here:


Best Regards,


0 Kudos
Message 17 of 22

Hi Ryan,

This was the place where I found the download link. Apparently it is not there any more.




0 Kudos
Message 18 of 22

Hey guys, that's weird, the document still shows there's an attachment but it doesn't appear to be downloadable. I tried removing and re-attaching, no luck, so let me try attaching it here. Let me know if you're not able to download this file.


Thanks! --Ryan_S

0 Kudos
Message 19 of 22

When I create a custom Asynchronous device, the project opens with certain code in conflict. Is this normal?



Michael Aivaliotis
VI Shots LLC
0 Kudos
Message 20 of 22