NI FlexRIO Network

Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

Issue with I2C EEPROM Simulation on FlexRIO

I'm attempting to simulate some I2C code which will write data into the adapter module EEPROM.  I have found that I can build the I2C code into a bitfile, however I can't get the simulation build to complete.  I get the following error (-61499):

I2C Sim Error.png

I noticed that if I disable some of the blocks:

I2C EEPROM RW Cal Data Disable.png

and then remove the i2crddata line and replace it with a constant (so: 'i2crddata' I/O pin would be replaced with a constant number '0' (in FXP) for example)

Remove i2crddata.png

It will build successfully and I have no clue why....

I've zipped and attached the LV project for reference which includes the full code and CLIP. 

Anybody know why this is happening?

0 Kudos
Message 1 of 2
(2,111 Views)
1 REPLY 1

Re: Issue with I2C EEPROM Simulation on FlexRIO

Hello!

For this issue, I would suggest creating a service request at ni.com/support with one of our Applications Engineers. They will be able to help debug/troubleshoot this situation as well as be able to access the applicable internal resources to investigate this issue.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Ben Sisney
FlexRIO V&V Engineer
National Instruments
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
0 Kudos
Message 2 of 2
(1,170 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.