Showing results for 
Search instead for 
Did you mean: 

Oscilloscope calibration



I am a new user of the NI ELVIS smx and am having a problem with what appears to be a calibration issue with the Oscilliscope. Find attached two examples (one DC and one AC) where I have used the function generators and analysed in Oscilloscope and in both cases there is a large negative offset of approximetely -2V. I read the manual and tried calibrating with MAX, and although all NIElvis device seem to work I am unable to get MAX to recognise devices - note I am running Windows 10 64bit.  


Pretty much stuck at the moment and will appreciate any advice.




0 Kudos
Message 1 of 6

Hi Hugo,


Have you seen this forum? It has some relevant next steps you could try.


Also, where are you measuring this signal from? Have you tried measuring it using another device?

0 Kudos
Message 2 of 6



Some limited progress. I ran my myDAQ and Launchpad MSP EXP430G2 of the same USB as I use a HP Pavillion X2 laptopt which only has ONE USB!!! I therefore use a USB hub. I then tried running MyDAQ direct on USB and not through hub and MAX recognised the MyDAQ (see MAX.jpg), but nowhere could I find how to run the calibration - the only thing that worked was running Test Panels. I did however manage to run a report, also attached. 


At this stage I did a software update and some Labview patch was installed, and I reperated the previous experiments of using DC Level to generate a signal and checking this signal with Digital Multimeter and Oscilloscope, and as previously DM measured correctly and OSC measures approximetely 2V too low. 


Following you suggestion I tried the only other signal source I have whicch was the Launchpad MSP which I used to generate a 3.5DC signal - and again DM measures correctly and blinking OSC again measures approximetely 2V too low - see Multimeter and Oscilloscope.jpg.


Any other suggestions?




0 Kudos
Message 3 of 6

Have you tried this on another computer? You should avoid USB hubs as they may not supply enough power to your device, especially if this is a laptop.

0 Kudos
Message 4 of 6



The USB hub is an independantly powered so should be ok but as you suggested I moved MyDAQ to a different PC with dedicated USB port but result is exactly the same - Oscilloscope still reading approximetely -2V less than signal.


0 Kudos
Message 5 of 6

Hi Hugo,


The fact that you're seeing the same behavior on multiple computers and with multiple signal sources makes me think that the issue is with the Scope itself. I vaguely remember having seen something similar before, and that one ended up needing to be RMAed. I would recommend calling into NI's Support line- they can help you troubleshoot, and if it ends up being an issue with the hardware, they'll put you in contact with the right department to guide you through the RMA process.


Kathryn K.
Technical Support Engineer
National Instruments
0 Kudos
Message 6 of 6