cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

MyDaq not recognizing

MyDaq not recognizing

Hi so I've been trying to connect myDaq to the computer and the blue light turns on for a few seconds then turns off. It seems like the computer isn't recognizing the device. I've used the myDaq on this PC before and the elvis launcher used to pop up automatically. All help is appreciated. Thank you 

0 Kudos
Message 1 of 7
(2,223 Views)

Re: MyDaq not recognizing

Hello Jerm_Joy,

 

That's quite interesting that the myDAQ was previously working on the same PC. Are you able to detect the device in the (Windows) Device Manager or NI Measurement & Automation Explorer (MAX)?

 

Would it be possible to run the myDAQ Troubleshooting Utility? This program can be downloaded at the link below. The results of the tests performed in that utility should help us get closer to finding a resolution.

 

NI myDAQ Troubleshooting Utility

 

Thank you and have a nice day!

 

---
Alex C.
Applications Engineer
National Instruments
ni.com/support
0 Kudos
Message 2 of 7
(2,196 Views)

Re: MyDaq not recognizing

Hi when I go to device manager it says unknown device 

0 Kudos
Message 3 of 7
(2,189 Views)

Re: MyDaq not recognizing

Did your PC recently go through any updates (perhaps an operating system change)? Also, have you tried connecting the myDAQ with another USB cable? Does it work when connected to other USB ports on your PC?

 

Which version of the DAQmx Drivers do you have installed? 

 

Have you tried right-clicking on Unknown Device and selecting 'Update Driver' from the shortcut menu? Does Windows automatically find the correct driver?

---
Alex C.
Applications Engineer
National Instruments
ni.com/support
0 Kudos
Message 4 of 7
(2,160 Views)

Re: MyDaq not recognizing

Hi, I plugged in the Mydaq into a computer at school and it works perfectly fine. My computer is running, and has been running since I installe the MyDaq software, Windows 10. 

I'm not sure which version of Daq drivers I installed, I just installed everything in the CD that came with the device. It says, "NI ELVISmx 16.0 Driver" Circuit Design Suite 14.0.1

0 Kudos
Message 5 of 7
(2,155 Views)

Re: MyDaq not recognizing

My problem has not been resolved if anyone knows a solution, greatly appreciated. 

0 Kudos
Message 6 of 7
(2,136 Views)

Re: MyDaq not recognizing

Hello Jerm_Joy,

 

Thank you for testing the hardware out on another PC. It sounds to me like there may be something wrong with the drivers installed on your Windows 10 PC at your home.

 

Did you have the chance to run the myDAQ Troubleshooting Utility? This utility can be downloaded in Step 1 of the article linked below.

 

http://www.ni.com/tutorial/11424/en/

 

If that test does not prove useful, could you try the steps in Step 3. c. iii ?

 

Please let us know if those steps prove successful. Thank you!

---
Alex C.
Applications Engineer
National Instruments
ni.com/support
0 Kudos
Message 7 of 7
(2,130 Views)