Showing results for 
Search instead for 
Did you mean: 

Digital Electronics FPGA Board Hardware Driver for Windows 10

Go to solution

This link appears to be dead now?

0 Kudos
Message 21 of 29
Accepted by topic author TGregor
10-24-2016 12:50 PM

I accepted Brian's solution because it made the board work on Windows 7 x64. He recommended this for Win7:


HOWEVER! For me, none of the previous posts actually solved the issue (for me) on Windows 10. Getting this all working took me more than a week to figure out, but I've consolidated some info here and hopefully this will save you some pain!


1. Install ISE WebPack using Brian's link or from

2. Make sure to say YES when the Xilinx installer offers to install Cable Drivers (which installs Jungo WinDriver)

3. ISE Webpack and Impact which, while officially unsupported, work just fine on Win 10. But there is a big bug that causes crashes when you open up a dialog to browse for a project or file in either app. The fix is here:


At this point, my personal experience was that the DEFB was still not recognized. And while I never did find a way to directly install the DEFB onto Windows 10, what DID work was to transfer the working Win7 driver onto my Win10 machine. It's a little tricky but not too bad, and while I CANNOT LEGALLY REDISTRIBUTE THESE FILES, I will describe where I found them on my working Win7 installation. First I copied these two files into a single folder on the destination machine.




The other necessary files don't have "fixed" names because the way that USB Enumeration works is that when we plug in the DEFB, it announces itself as:

Vendor ID (VID): National Instruments = VID_3923

ProductID (PID): = PID_73EE

These values are stored in the Windows Registry when the board driver is installed, and point to a file located in:


But the name of the file? We don't know, because it gets assigned to the next available index. On my PC it happens to be named oem161.inf. What you have to do is navigate to the C:\Windows\Inf directory on the Win7 Machine and then SEARCH using the info that we DO know, which is the Product ID. If you type "PID_73EE" into the Windows search box for C:\Windows\INF you should be able to locate the exact name of the file.


Copy this into the destination folder on the Win10 PC, along with any other files with the same name and different extensions. On my computer, there were two files: oem161.inf and oem161.PNF. Remember, they will NOT have the same names on your computer (in fact, what the file is named doesn't matter at all).

So now, on your destination computer, you have a folder containing:







And you "should" be able to right-click on {generic_name}.inf to install it. But there is one more problem. Windows will almost certainly refuse, claiming that the .inf file is not signed. True! The original installation file was, but not the version copied into C:\Windows\Inf by the original installer. To temporarily turn off the signed driver enforcement on Windows 10:


[Search] Recovery Options

[Left-Hand] Recovery

[Right-Hand] Advanced startup

[Next] Choose an option: Troubleshoot

[Next] Troubleshoot: Advanced options

[Next] Advanced options: Startup Settings click [Restart]


An options menu comes up when you reboot. Choose:

Disable driver signature enforcement


Navigate to the folder with the copies files. Right-click on the .inf file to install. You should get a pop up dialog telling you that the installation was a success and your NI Digital Electronics FPGA Board should now work on Windows 10!



Tom Gregor


NOTE: This is provided for informational purposes only. Use it at your own discretion: It comes with no warranty express or implied. You alone are responsible for obtaining any licenses you need and for backing up and subsequently not breaking your computer if you choose to try any of this.



Message 22 of 29

Request to NI -

Would you consider publishing a zip download containing...



{original_signed}.PNF    // Is this one is actually needed?


xusbdfwu.sys make it easy to enumerate the DEFB on Win10? I can't redistribute them but you could.


0 Kudos
Message 23 of 29

Hi Tom,

Wow that is a thorough answer. I had noticed that I couldn't get the driver to stick and kept forcing it in. Haven't used board over the weekend as I'm on holiday so my missus has been keeping me busy. Hopefully ni will release an easy to install driver. It would also be good if the driver package download was less than half a gigabyte just to get the board connected. 

Thanks for taking the time to note the process.



0 Kudos
Message 24 of 29

Hi All,

A few more thoughts.

I am back at work now, and can communicate with the board reasonably well and consistently.  I managed to force some drivers in, but do struggle with the official NI drivers as they fail every time as my "My Documents" is a network location.

Anyway, once I have the driver in I can then get Multisim to detect the board, but I have to select Xilinx ISE 14.7 64 bit.  If I choose 32 bit it doesn't connect.

I am having bother getting Multisim 12 to produce a program for anything but the most basic schematic.  It works for the circuit with just an AND gate and OR gate, but doesn't work if I try and add a JK flip flop.  I have tried studying the output window and even copied it into word, but I can't see anything obvious.  Are there any obvious pitfalls I should be avoiding?




0 Kudos
Message 25 of 29


i used the compatibility option to run the driver .exe in windows 7 compatibility mode while in a windows 10 machine and it worked for me 

Message 26 of 29

I hate to drag up an old thread like this, but this was by far the most helpful place I've found to look. I've got a bunch of the same boards that I'm trying to get running on Windows 10 as well. I got them working last year (under Win10) and had no issues, but we're transitioning to new computers. I've installed MultiSim 14.1, Xilinx Tools 14.7, and the FPGA drivers. MultiSim recognizes the board without issue, but programming fails. Any ideas?


In MultiSim's huge pile of output, the thing that stands out is 'Process "Synthesize - XST" failed'.

0 Kudos
Message 27 of 29

Hey Joe,


Xilinx ISE no longer supports Windows 10 so you're likely running into an issue when Multisim communicates with the ISE API (that was installed with Xilinx Tools 14.7). Specifically, the new Windows 10 Creator update is the culprit here which causes the ISE failure.


We're working on a KnowledgeBase article right now that will give you explicit instructions on how to get it working again but until that is ready you should be good to go by disabling "SmartHeap" as detailed in this support article from Xilinx:

Brian H. -- Electronics & Measurements Product Marketing Manager
Message 28 of 29

Worked like a charm. Appreciate it!

0 Kudos
Message 29 of 29