NI製品ディスカッション

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-DAQmx PythonをCommand Line Interfaceで動かしたい

NI-DAQmx PythonをCommand Line Interfaceで動かしたいのですが可能ですか??

環境としてはarm cpu搭載の端末(jetson)上でdockerを使って動かしたいです。 docker上で動かないのであればarm cpu搭載の端末(jetson)上で動かしたいです。

0 Kudos
Message 1 of 2
(153 Views)

ちなみに試したみたことは下記なのですが、どうもni-daqmxのpythonのライブラリがarm64のCPUアーキに対応していないみたいです。

というのもJetson端末でのdesktop ubuntu上にni系のドライバーを入れようとしていて、つまづいています。

 

N: Skipping acquire of configured file 'ni/binary-arm64/Packages' as repository 'https://download.ni.com/ni-linux-desktop/2020.07/deb/ni/bionic bionic InRelease' doesn't support architecture 'arm64'
W: GPG error: https://dl.yarnpkg.com/debian stable InRelease: The following signatures were invalid: EXPKEYSIG 23E7166788B63E1E Yarn Packaging <yarn@dan.cx>
E: The repository 'https://dl.yarnpkg.com/debian stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

 

mac側のvirtualBoxでinstallしたらうまく行きました。

下記はdockerでやる手順ですが、ubuntu側では全てsudoで実行しています。

上記のエラーはsudo apt-get install -y ni-daqmxを実行したときに出るエラー内容です。

 

RUN apt-get update RUN apt-get install -y wget gnupg tzdata dkms unzip RUN apt-get clean RUN rm -rf /var/lib/apt/lists/* RUN wget https://download.ni.com/support/softlib/MasterRepository/LinuxDrivers2020/NILinux2020DeviceDrivers.z... RUN unzip NILinux2020DeviceDrivers.zip RUN apt-get -y install ./NILinux2020DeviceDrivers/ni-software-2020-bionic_20.1.0.49152-0+f0_all.deb RUN apt-get clean RUN rm -rf /var/lib/apt/lists/* \ RUN rm -rf NILinux2020DeviceDrivers \ RUN rm NILinux2020DeviceDrivers.zip RUN apt-get update RUN apt install -y ni-daqmx RUN dkms autoinstall

どなたか分かる方いますか?いないですよね。。。??

0 Kudos
Message 2 of 2
(85 Views)