Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

word generator out of sync with hex display and lamps during Burst and Step mode of the Word Generator (in multsim 13)

Highlighted

Hi

 

I am having severe problems using the logic simulation in Multisim 13 of a pure logic circuit. The circuit has to convert a 4 bit binary code into a decimal number made visible on 2 hexadecmial display units. I am using a subcircuit to make it better readable. The wordgenerator is programmed to make 12H steps, starting with input 0EH en running to 0H on the lowest 4 binary lines. It has to ron at 200 Hz, so after the burst is done all 16 binary input combinations will have passed by. It all runs beautiful, see the added pictures.

 

What  is wrong?

 

The 4 Lamps X1..X4 attached to the 4 binary signals show the logical values of the binary word generator outputs. Also a separate hexadecimal display U1 is used to show the hex-value. That works fine too, they both agree and give the same values. On the input terminals of the subcircuit SC1 is of course the same set of binary values on the Logic Analyzer this can be verified. Also, the outputs of subcircuit SC1 gave the right values voor "15" on a hexdisplay. you can check this in the Logic Analyser's timing diagram: all is fine. The same outputs of SC1 are also brought to a set of two 7-segment HEX displays

 

But there it goes wrong! Both 7 segment Hex displays together show "00" which should be "15" as can be seen in the Logic Analyser output!

And when I use Step in the Wordgenerator, it happens also now and then that this discripancy happens. I find this very annoying and hard to explain to my students.

 

What is wrong with this logic simulation in Multisim 13.1 ???? 

0 Kudos
Message 1 of 9
(3,066 Views)

Hello.

I was able to reproduce your situation.

 

I use MS14

 

the key is to pay attantion on freq setting of world gen-r  -

if it is low as 50 Hz - it works fine in all modes.

but when it is high, like 200hz or even higher like 2000  , it begins to bumble - and as higher freq as more mistakes.

 

I guess there is problem with calculations and posible work out is to use low freqs for simulation/

 

 sorry, no images, I do have screen captures, but  these files are too big

 

with hope it helps

 

good luck

 

Michael

0 Kudos
Message 2 of 9
(3,035 Views)

Hi Michael, reading your reply about not having a screen capture tool, I have good news for you. If your running windows, then you do have a built in capture tool and a nice one at that. It is something included with Windows, but one of those things you have to stumble across which I did one day, and now I capture screen images with ease Smiley Happy

 

The tool name is snippingTool.exe and you can envoke it from your run window, or make a shortcut as I did. I just thought I would mention it based on what you said earlier, and I hope it helps you out.

See image below.

 

Cheers

sniptool.JPG

0 Kudos
Message 3 of 9
(3,034 Views)

hello , thanks for the info.

 

I guess I did not explained my self properly.

 

the matter of fact I do use screen capture tool (Snagit32) and I have made a few videos for that post.,  but, they are too big and that forum does not accept mp4 file extension.

 

 

 I just tried that Snipsnip tool - it works fine for sreenshots, but does not do videos.

 

 thanks for replay anyway -

Michael

0 Kudos
Message 4 of 9
(3,031 Views)
Hi Michael
thanks for your response. I am happy too you could reproduce the problem. About Multisim13: i have 14 installed too, it doesn't make a difference here, the problem persists. I have to use 13 for compatability issues and in other couses courseware is based on and written for 13, that's the way things go in the educational world.

then back to the problem. I did try lower frequencies even as low as 1 or 2 Hz. but then Multisim became unacceptable slow. At 20 or 50 Hz I thought to have seen the same errors, especially during single stepping. I know this simulator from the early days, right from the start, when it was called electronic workbench and then i was always able to make pretty good single step simulations but now with this latest version of multisim i don't even try it, burst is the only usable option left. Until sofar, because with this new problems I am dissapointed how hard it is to get the Wordgenerator and Logic Analyzer to work together in a decent and reliable way.

I noticed that for a good burst result i always need to stop the simulation first, even if it stops by itself after a burst of say 22H steps and then I must reset both WG and LA in that order before rerunning the burst and get the same results on the LA screen. The simulator is very sensitive to do this in this particular way. Even then at the end of the burst i still have the error of the wrong output display in a random manner
0 Kudos
Message 5 of 9
(3,004 Views)
The reason I came back to Multisim is that it visualizes in a cute manner how a testbench can be made and used. For students at the entry level I was hoping to make a working setup for rather simple logic circuits. The real target is VHDL, where we do this stuf in almost the same way, only there it goes more abstract. However I still would like to make this here work accurate and smoothly. For the 2nd lab i am now preparing more or less a simular setup but this time a 4 bit adder will be the target and the subcircuit SC1 in particular will change significantly. In fact the SC1 is the DUT, the Device Under Test. Students will have to program the WG in such a way that the SC1 will be test for a serie of additions, this will have to be done a few times in one burst. The LA should reveal if their adder works right. But i fear MS13 will show again wrong things after the burst.
0 Kudos
Message 6 of 9
(3,000 Views)
about transferring video or other rather big files, maybe the app Telegram is an idea: that one is a Whatsapp alike messenger and it works beatyfull when transferring files of any kind, including large videos. the nicest thing is that it synchronizes accounts and screens over iPad, Android and Windows platforms, very handy!
0 Kudos
Message 7 of 9
(2,997 Views)

Hi Michael

I tried 20 Hz .. 50 Hz and yes you're right, there is a sensitivity for above around 30 Hz, then the errors became worse. At 20 Hz it almost runs flawless.
But even knowing this, I still consider this as a bug in Microsim: it should be not that sensitive to this setting.

 

Thanks anyway for you response.

 

I will post also the lab2 circuit later on, once I have tested it more thouroughly.

 

Kind Regards
Peter J

HAN University,

The Netherlands

0 Kudos
Message 8 of 9
(2,983 Views)

Hello, thanks for response

so if it solved your problem - check that post as solved/

with hope it helps
good luck

thanks
Michael

0 Kudos
Message 9 of 9
(2,936 Views)