Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

unable to get a crystal working in multisim

Can annyone help me.
I trying to make the circuit (Crystaloscillator) work from in multisim.
The crystal does not oscillate and the exit shows no freq.
I think it has to be in the setting from multisim 9 but i am not sure.
thx Ed.
0 Kudos
Message 1 of 7

I do not have Multisim 9, but I do have Multisim 2001 Power Pro. That said, I put the circuit into my Version and it did not work with the Virtual Crystal at all that I observed. I also tried other Crystals that I have in my Misc. Database. It would not work with anything less that the 1.5 MHz Crystal. At 1.5MHz and above the circuit seems to work O.K.

I don't know if your version has different models for the Crystal, but you might want to look into this and see.

Kittmaster's Component Database

Have a Nice Day
0 Kudos
Message 2 of 7

Thanks for trying.

I did try this also in multisim 2001 with various crystals, fets and transistors but still no result.

The only thing I find is that the transistor is open and it stayes open.

0 Kudos
Message 3 of 7
I am kind of at a loss at to what is happening now. I do have some suggestions that you could try. If you are using the O-scope, try setting the channel coupling to AC. This will elimante the DC component of the signal. Then try running the voltage per divisions down. I am thinking that the scope set-up is tricking you into thinking it isn't working when it actually is, but this is just my theory.
Kittmaster's Component Database

Have a Nice Day
0 Kudos
Message 4 of 7

Found the Problem!!!  Under the Simulate Tab. Click on Default Instrument Settings. Under the Intial Setting Title there is drop down box.. Click the little arrow beside it to expand the box. Find where it says "Set to Zero" and click it. Then hit the Accept button at the bottom. This should cure the problem.

I was playing around this morning with this circuit, and was trying various ways to recreate your malfunction with it. This is what I found. Unless the intiial condition are "Set to Zero" it does not work, period. I guess I didn't see this before, because I always set up my simulations with intial condition "set to zero". I find most circuits work better (at least for me) with this option turned on.

Kittmaster's Component Database

Have a Nice Day
Message 5 of 7


I think the O-scope  is not the problem.

Perhaps you can tell me what the values are by measuring over the resistor R2  ...Volt   and the value at the base of the transistor T2. When I connect the O-scope between R2 and the transistor it shows a voltage of 5V same as power supply -0.8V for the transistor and no sinus what so ever( not even when i set the O-scope at AC and select 1pVolt  it shows a little square wave of -0.089pVolt and 0.147pVolt) this is too small for normal operation. I use the default settings for simulation perhaps this is wrong???

thx for helping Ed



0 Kudos
Message 6 of 7
Thanks, you where right i changed the simulation settings to "set to zero" and i finaly have a reading.
Thx Ed
0 Kudos
Message 7 of 7