Multisim and Ultiboard

cancel
Showing results for 
Search instead for 
Did you mean: 

ultiboard

Hi ..
     I'm new to this foram..
     I'm facing one seroius proble in Ultiboard..!Smiley Surprised

     if any quad Flat package part (QPF) import and rotate by 45 degree, it thrown an DRC error..

 

I'm tried to resolve it.. But  I'm unble to do. please help me on this..

 

Thanks in advance..Smiley Happy

 

rmk_mani

0 Kudos
Message 1 of 5
(4,331 Views)

Hi,

 

Without looking at your design file, it's hard to say why you are getting the DRC error. The most common reason for DRC error is clearance; this means objects too close according to the design rule. Select View>>Clearances to display the clearances, double-click on one of the design rule error on the spreadsheet view to zoom into that error, if you see the clearance outline around one object touching another object, it means you have a clearance problem.

 

You can fix a clearance problem by moving the objects further apart, but in some cases this is not possible especially for small components. In this case, you have to adjust the design rule such as reduce the clearance for the nets or reducing the trace size. You can adjust these settings under the "Nets" tab on the spreadsheet view.

 

If you can’t figure out the problem, post your file. You can delete most of the components on your design to keep your design private just leave the QPF and maybe a couple of other parts so that I can see the DRC error. 

 

Tien P.

National Instruments
0 Kudos
Message 2 of 5
(4,310 Views)

Hi Tien,

            Thanks for your reply..
            Please do the excercise in Ultiboard, you can find the error..
Step 1: open the Ultiboard any version 8 or above..

Step 2: Create new project (I mean new board )

Step 3: Add your board size using Board boarder layer [my size is 10x5mm]

Step 4: insert any one of Quad Flat Package [QFP] package footprint from Surface mount part's database [like , under database.....IC>flat>TQFP].

Step 5: Notice that..Once you inserted there is noDRC error in that part..

Step 6: Just rotate the part with 45 degree.. you will find the DRC error without any net/ trace even any other extra component.

 

Even, I have done with 0 Clearness to each and every pad also..

 

Please find the root case. and please share the solution with me..

 

Thanks in advance..

Mani

 

0 Kudos
Message 3 of 5
(4,306 Views)

Hi Mani,

 


This could be a component specific problem. I was able to find a footprint that had the same behavior as you described and this is how I fixed the footprint

 

1.  Place the part on the workspace 

2.  Select the part then Edit>>In Place Edit Part. The In-place editor feature may not be available in your version, if you don't see it, you need to save the footprint to your User database and then edit the part through the Database Manager. Refer to this knowledge base for more details:

http://digital.ni.com/public.nsf/allkb/8A20C35B155A5F3086257806006040BE

3. Use the selection filter; disable everything except for SMT pads. Now select Edit>>Select ALL to select all the SMT pads

4.  Double-click on one of the selected SMT pad to open the pad properties dialog

5. Make a small change to the SMT pad properties such as radius, width etc... then click Apply.

6. Exit the In-Place Edit mode and the error will disappear.

 

After is a file to show the problem, I modified C7.

 

Tien P.

National Instruments
0 Kudos
Message 4 of 5
(4,301 Views)

Hi Tein..

 

     Thanks a lot.. you have fixed my problem..

 

regards,

Mani

0 Kudos
Message 5 of 5
(4,289 Views)