Multisim and Ultiboard

Showing results for 
Search instead for 
Did you mean: 

net rename bug

When i rename a net to an user friendly name , for example POWER, or 5V, or anything, and then connect it to an other wire, then the name is lost, and renamed to a number.

Also renamed if i make a junction. Then its impossible to expand a net without loosing its name. Its lame.

I try to lock the net name, but the lock is only for the position of the caption, not for net name.

0 Kudos
Message 1 of 15

Hi lidi


I tried to reproduce the error you mentioned. It is not happening in my case. Sometimes the net name moves to a different position, sometimes the label disappears (the "Show" option turns off when you double-click the connection), but in every case, the cable name stays. 


In order to solve this issue, I will need some additionall information from you:

- what Multisim version are you using?

- can you write a short, step-by-step description (in points), how to reproduce the error?


Thank you in advance
Best regards,
Maciej Antonik
National Instruments Poland
0 Kudos
Message 2 of 15

Today i try to reproduce this, and record with screen recorder software. But today everything is working fine.....  Smiley Surprised  strange!

Maybe if this coming up again, then i will immediatle making a record.

0 Kudos
Message 3 of 15

I have also seen this bug in Multisim. The next time I am building a schematic I will take notice and record what is happening if someone else does not get to it first. I just wanted to post that you were not alone in this bug...



0 Kudos
Message 4 of 15



Even if you can't see the error right now, please provide your version numbers - just for the record. I also recommend trying this with a cable connected to ground or power sources - I noticed that the behaviour of those cables might differ sometimes. Let me know if ever you see the problem again. If you do, try to prepare some simple steps to reproduce it. 


Good luck!

Message Edited by Maciej Antonik on 01-13-2009 01:39 AM
Best regards,
Maciej Antonik
National Instruments Poland
0 Kudos
Message 5 of 15

Hi all,


I think the current Multisim's behaviour will rename the connected net to which ever netname you made the connection to.


So, for example:

  1. You create a net, by default it will be named something numerical, like "1".
  2. You create a second net and it gets another numberical netname, for example, "2".
  3. You change the netname of the first net something like POWER.
  4. Now, lets say you want to join the two nets. If you start by clicking on POWER and drew the connection to the net 2, you would end up with a single net named 2. However, if you did the exact opposite (clicked on 2 first and connected it to POWER), you will end up with 1 net named POWER.

 Multisim does this to arbitrate between possibilities of many net names during net creation. At least the behaviour is consistant and predictable.

Software Developer
National Instruments - Electronics Workbench Group
0 Kudos
Message 6 of 15

My version is : 10.1.357

And when the error is present, then renamed the net if i just place a junction to it. 

0 Kudos
Message 7 of 15

I am also using version 10.1.357. This does not happen all of the time for me. In one case that I recently worked on, the net name would change by either connecting another net to it (understandable) or it would change if I only placed a junction directly on the net. The net name would then be changed to the next available net number. Again, it doesn't happen every time but it does happen enough to be bothersome to me.

0 Kudos
Message 8 of 15



I checked in 10.1.197, and when performing the following steps:

1/ place a wire

2/ rename the wire

3/ add a single junction anywhere on the wire

the name persists as expected. Is it differently in your case? If yes, please provide precise steps to reproduce. In the meantime I will try to get exactly the same version



Best regards,
Maciej Antonik
National Instruments Poland
0 Kudos
Message 9 of 15

I was able to play around with this a little more. Here are my observations. I was able to try this in Multisim Power Pro Edition Version 10.0.343 and 10.1.357. I got similar results.


1. I placed a wire on the schematic. 

2. Change the name of the net

3. Added a junction.

 At this point the name stayed the same so I went further.

4. Started to add components to the net.


In Version 10.0.343, the net name changed on the fifth component added to the net. In version 10.1.357, the net name changed on the fourth component added to the net. Both changed to a net number. Then funny things start to happen if you have the net name shown on the schematic. Once, the net changes to a number, it updates what is shown on the schematic correctly, but if you go an change the net back to some name I specified, what is show on the schematic does not change. Checking the box to show the net or not did not make a difference. It would get stuck showing the number. The netlist report was correct however. By moving the components connected to the net, I was able to get it to refresh correctly to the name but as soon as I add more components to the net, the net name would change back to a number.


Thanks for your help,


0 Kudos
Message 10 of 15